Koodo Community



Skype will not run on my new Moto G4 Play

Installed Skype from Google Play. App starts and is very slow logging in. It then progresses to the point where it is totally unresponsive and then the system message pops up saying it is not responding and do I want to close it.

I have tried uninstalling, restarting the phone and reinstalling and nothin helps.

Note: I have a 128G SD card installed as internal memory, if that has any bearing on the situation. Also I have no issues with any other app.

Any ideas?

3 replies

Userlevel 7
Badge +4
Try downloading an older version of the application to see if it solves the issue.
Badge +4
I ditched internal storage and opted for portable storage instead, (Moto X Play). I began noticing subtle performance issues with certain apps, (slightly longer load times). Even with a high-speed 64 GB UHS-1 card installed, two apps would perform sluggishly or ask to close for no reason. Those same apps worked flawlessly prior to switching to internal storage. No issues once I switched back to portable storage. Unfortunately, I'm nowhere near my Moto X Play to replicate the issue. I recall one of the apps was Sygic Navigation because I had to contact the developer for assistance. I'm thinking Skype was the other app, but I'm not 100% certain. Give it a try anyway and keep us posted.
Reset the phone and set up the SD card as portable storage. Installed Skype and it worked fine. Thanks for the suggestion

Although on another note, there is a huge issue using the recommended high speed SD cards as internal memory. It seems almost nobody has much luck there