Koodo Community



Sim card + DATA connection Bricks phone cause complete blackout?

Hi, I recently bought a Chinese phone that has dual Sim ZOPO 980 and wanted to use the same sim card in my iphone in my zopo the first time I put the sim card in it worked but I had changed my IMEI in the zopo to be the same as the iphone. TWO days later I did a hard reset on my phone and reflashed everything and then went to put in the sim card it said invalid IMEI. I realized that the IMEI HAD returned to it's orignal number so I changed it but now I put the sim card in the phone starts the boot and as soon as it tries to establish a connection the phone SHUTSDOWN and goes completely black is this a software issue or is this a carrier/ IMEI security issue?

4 replies

Userlevel 7
It... wait, what? The SIM can't change the IMEI on the phone, you're probably just putting it in the other slot. This also shouldn't be messing with the boot operation but if you're screwing around with IMEI numbers and flashing, etc. it could be ruining normal operation of the phone. Besides, I checked out the specs on that phone and your coverage/reception won't be as good because it only has the 850 band. I don't think it'd be worth the trouble.
Well you didn't actually answer the question unless your saying software is the issue. I however need to know if this is problem is caused by the carrier. Or can be caused by the carrier due to handshake not being up to snuff. This would be a personally victory to fix the problem and the phone is highly modified so yes it would be worth it the phone is awesome . Why else would I spend130 hours of my time trouble shooting this 1 months if weekends . I'm starting to get really good with android but still need a good 4 more weeks. Plus as I said originally I have tested the speed and signal on HSDPA h+ and it was amazingly fast . I need someone to direct me to the resources on how dermine if this is hardware/ or carrier issue preferably I would like to discount it being carrier issue.
Userlevel 7
It's tough to determine if it's a carrier issue if the phone is failing to boot when establishing a connection. Can you try another provider's SIM to see if that makes a difference?

Also if by highly modified you mean rooted and/or running a custom rom that could be messing with the boot process too.
I have tried another's carriers and it worked on the gsm network/ however it did not work on the wcdma network.
Gsm = no problems good speed but rogers sucks and like Koodo lol. And yes it is rooted and root requirements for a lot of the apps I'm running . I realize its very difficult to diagnose. I'm guessing by boot process you mean booting up the sim and connection as phone starts searching for network makes connection.
I usualy get a message saying I have 1 new voicemail that's when it bricks need to pop out battery reapets every time . I do appreciate your responding to my inquiries. If it doesn't work out my zopo will become my test/ build my own apks platform:) but I was hoping maybe by chance someone has encountered this problem.and this just might be a wcdma setting CDs info or something along those line that I have regrettably tampered with and stopped the function of the phone.perhaps a checklist of all the things that need to be enabled ;+)