Koodo Community



Sending/Receiving MMS..... but no data on plan

Hello. I have a nexus 5 and was wondering if there is a way to send and receive pictures through text without turning on data. It says I have mms but do not understand how it works if I do not have any data. I do not have any data and I do not want to turn on the data to send pictures (might accidentally charge me a bit of usage for data 😕 ) So any work around this? I heard some phones can turn on/off data automatically... Thanks for help

9 replies

Userlevel 7
I'm just going to copy this from a previous thread and it should help you out. ********************************************************************************************* Can you send regular text messages but not picture messages? SIM CARD BASED phones require a data connection in order to send those messages. So if you have data turned off, or blocked, these messages won't go through. "But wait" you say "My plan includes unlimited text and picture messaging. I want to use it but I don't want data because I feel it's too expensive (or whatever)". The Mobile Masters have your solution below. You can enable data by navigating Settings / Wireless and networking / Mobile Network Make sure 'use packet data' or 'enable data' is checked. If you have data blocked by Koodo you'll need to unblock it. You'll have to call customer service to have the block removed. Follow the methods below to ensure data is only available to picture messaging. Setting up A Koodo phone for MMS with no additional Data Access FOR ANDROID DEVICES -=- for iphone 3GS see Note 2 First We need to do a little housekeeping. Navigate to your current messaging app and delete any picuture message you previously tried to send but have failed. Next: Navigate to Settings / Wireless controls / Mobile networks / access point names METHOD 1. Find the Koodo.sp Apn and tap it to open it. Some phones will allow you to edit this APN, for those phones which will not allow you to edit the default APN (I.E the Samsung Galaxy S2x), please skip to Method 2. Tap APN type and change it so it reads only "mms" then tap the menu key and select save APN once saved the 4g indicator should disappear. Please see: Note 1 METHOD 2 You'll be creating two APN's Add the first apn (usually by hitting the menu key and tapping ADD NEW) Note: in the example below please omit the spaces between the http: and the address This is done because some websites shorten URL's Input the following settings (leaving designated fields blank): APN NAME: Koodo (NoData) APN: spp.koodo.com Proxy server: Port: Username: Password: Server: MMSC: Proxy server: Port: MCC : MNC : APN type : default For APN Type we use "default" for this example but if it doesn't work for you, go back and change it to "Internet" Save this entry (usually by hitting the menu key and selecting SAVE) Now create a Second APN using the following settings APN Name: Koodo MMS ALLOW APN: sp.koodo.com Proxy server: Port: 80 Username: Password: Server: MMSC: http: //aliasredirect.net/proxy/koodo/mmsc Proxy server: Port: 80 MCC : 302 MNC : 220 APN type :mms Now save this entry as you did the first. On the list of available Access Point Names you'll notice three (or more) entries. Select the Koodo (NoDATA) APN and make it active (you'll notice you can not choose the Koodo MMS ALLOW entry) Exit the APN menu. Reboot the phone (Shut it off and turn it back on) Turn off your WiFi Open your browser and attempt to access any webpage other than Google (google is normally cached). You should get a message that the page cannot be displayed. Note 1: (For Everyone to read) You'll notice the 3G or 4G data indicator has disappeared leaving only the Signal strength indicator. IF YOU HAD PREVIOUSLY TRIED AND FAILED TO SEND PICTURES IT MAY TAKE A FEW MINUTES FOR THE INDICATOR TO DISAPPEAR. When you do send a picture the Data indicator will re-appear and the picture should be sent. The Same thing will happen when you get a picture message.
Ahmad wrote:

I'm just going to copy this from a previous thread and it should help you out. *****************...

This worked wonderfully on my Nexus S.  I just upgraded my phone and followed the same steps.  I restarted the phone and turned off Wifi, and cannot access the internet.  Does this mean it's working properly for sure?

When I send a picture text it still shows the H+ icon, so I am assuming it isn't working.  This is very frustrating as my plan has always included unlimited text, including picture text, and Koodo even says several times on their website you will not be charged for sending picture texts.  Yet I'm already getting an overage charge for sending picture texts.  I don't feel like it should be so confusing to set up. 
Hello, OP here. I called support regarding a charge on data. I asked her the issue regarding this matter and it got me a little upset. She told me that if I wanted to send and receive pictures I would have to pay the data charges involved every time. Even though when I purchased my plan it says I can send and receive pictures free, it is still forcing me to get data to avoid additional charges. I have no done what you have said Ahmad, but are you sure I will not receive a charge for using data or is this sending/receiving pictures a complete scam to force people to buy data?? Thanks for reading.
I just tried this and I was not successful. Ugh.
This did work up until a few days ago. With the Android 5.0.1 update something happened which bypasses the NoData apn and goes straight to Data without even changing the radio button to Data.
Userlevel 7
Please keep in mind that this workaround will not work on every device and that updates by the device manufacturer can break this workaround.
Great work around.  It was a little touchy at the beginning, but it seems good now.

Any way to also allow access to the Koodo app with this workaround?  I doubt it since we are blocking all network connections, except mms.  The Koodo app wouldn't happen to have its own connection type, would it?

Thought it was working on my S4 as it allowed me to send a picture. Once image was sent though data connection remained open and I was able to access the internet. I checked Internet access b 4 sending picture and I couldn't access it. Is there a fix?
Works wonderfully for my D852 running CM 13-20160104
Thanks for the tip, didn't even know that was possible.