Koodo Community

Community

Solved

Samsung s3 still using 3g when connected to wifi


Hi there, bought a Samsung S3 for my wife. Set everything up and seemed fine. However 2 days in she gets a message that she is going over her data limit. This entire past 2 days, despite being home where we have wifi the phone has been using its data connection? Now her data has been turned off and I don't know why the phone was using data instead of wifi. Anyone know what the problem could be?

6 replies

Userlevel 7
Check under the advanced wifi settings for the wifi sleep policy. It should be set to never. Wifi sleep turns your Wi-Fi connection off when your screen is off to save battery.
ok I have been doing some reading I don't seem to have any advanced settings available to me? when i go into settings, then network connections, then wifi all i have is smart network switch and a list of available connections sorry im a mac guy brand new to android ....
nevermind i just found the buttons that gets me to advanced settings FINALLY hmm was set to always keep on during sleep already ....
Userlevel 7
Okay so the next step is to make sure your wifi signal is strong enough keep connected to your device. I'd recommend rebooting your router and while you're at it you should also restart your S3 daily.
OK I have power cycled my router and modem for different reasons related to my macs. I'll reboot the phone, that is a good one for sure. Here is a question, how do you know when there are advanced settings? I accidently hit that left button while on wifi and the menu came up, but I'm looking to install a launcher and cannot find where that would be. Is there a setting like in windows, like 'show all hidden files' or you make all settings advanced? Sorry for all the questions, I'm finding android a bit hard to learn.
Userlevel 7
Usually (but not always) that left button will act as the overflow menu button. Sometimes you'll also see "..." Meaning there is more.

Reply