Koodo Community

Community

Solved

Samsung s3 keeps saying Koodo is not available!!


12 replies

Userlevel 7
How long have you had this problem? it could be because of a number of things. try resetting your network settings or a battery pull out. MAKE SURE you have 3g enabled.
for about 3 weeks ...i tried all of what u said it didnt work..except for the 3g:) how can i enable the 3 g?
and sometimes it says not regiseterd on a network
Userlevel 6
Hi Rabab! I was about to suggest rebooting your phone, but you already did all that (battery pull and everything). Do you have access to another Koodo (or unlocked) phone in which you can try your SIM card? If you do, please try your SIM in a different phone to rule out a faulty SIM. If you do not, your nearest Koodo kiosk will be able to make this test for you. In an even rarer case, your phone's SIM slot connector [i]may be faulty, but it's really not common. Please test your SIM in another phone and report back. We'll go from there 🙂 Cheers!
Userlevel 6
Some random Mobile Master wrote:

Hi Rabab! I was about to suggest rebooting your phone, but you already did all that (battery p...

Rabab, I just noted your problem seems to come and go... Do you live in a well covered area? Is it better if, for example, you go outside? Waiting to hear from you!
Some random Mobile Master wrote:

Hi Rabab! I was about to suggest rebooting your phone, but you already did all that (battery p...

yes i'm living in a covered place ..but it used to work very good , and this msg appears every where not only at home ...it started like 3 weeks ago for few hours through the day,,,,but for the last weeek its completely dead !!:)
Userlevel 6
Some random Mobile Master wrote:

Hi Rabab! I was about to suggest rebooting your phone, but you already did all that (battery p...

Ok Rabab, in this case, refer back to my post. Do you know anyone with a Koodo phone (or an unlocked one, like a Nexus for example) in which to test your SIM card?
Some random Mobile Master wrote:

Hi Rabab! I was about to suggest rebooting your phone, but you already did all that (battery p...

no.
Userlevel 7
Badge +4
settings->more settings make sure flight mode/airplane mode does not have a green checkmark beside it settings->more settings->mobile network make sure network mode is set to GSM/HSPA/LTE auto mode tap on network operators search networks select koodo.
yup i've tried all of this:) i guess there is something wrong with my sim card . i think i have to visit any koodo kiosk to check it out
Userlevel 3
Rabab Elfouly wrote:

yup i've tried all of this:) i guess there is something wrong with my sim card . i think i have ...

Eighther the sim card or the phone. Hopefully, it's the sim card....
Userlevel 3
Rabab Elfouly wrote:

yup i've tried all of this:) i guess there is something wrong with my sim card . i think i have ...

I had the same problem with my Mobile Internet stick from Bell. It was a bad SIM card. Get a new SIM card. 🙂

Reply