Koodo Community

Community

Solved

samsung galaxy S6 MMS not working


I recently purchased an unlocked Samsung Galaxy S6. Everything was working fine for the last month. Seems that overnight, my MMS no longer works. I've tried resetting the network, I've turned the airplane mode on and off, I removed the current APN and put it back in... nothing. I can't receive or send pictures via text. My data is on, there are no restrictions. I already tried removing the SIM card and putting it back in. I've tried rebooting several times and it still doesn't make a difference.
I have a monthly plan, 1G of data, I use wifi - all other aspects of my phone work.. internet, apps, etc. did something happen since the 13th November? My last image received by text was at midnight on the 12th/13th November.
Any suggestions, please?
Thank you.

12 replies

Hi, you might want to try reset to factory settings but you need to save all your important stuff first ie pictures, notes, passwords etc Cuzco they will be lost.
Thanks... i really dont want to do that LOL. I will keep that in mind as a last resort.
Userlevel 7
Goto settings apps and clear the cache for your messaging app. Of that doesn't work try using a different messaging app like handcent or ChompSMS
Chad Burr wrote:

Goto settings apps and clear the cache for your messaging app. Of that doesn't work try using ...

Thank you! It never occurred to me to try a different app. 0 issues now. Clearing the cache didn't work in the stock messaging app.

Userlevel 4
Hi Michelle, would you mind turning your phone off/on and try sending a picture message to yourself? Make sure your cellular data is not turned off. thanks 🙂
Levis wrote:

Hi Michelle, would you mind turning your phone off/on and try sending a picture message to yourse...

Hi Kevin, that didn't work.. yes data is on... but that's OK.. Chomp SMS as suggested by Chad works like a charm. Thanks!

Userlevel 4
Levis wrote:

Hi Michelle, would you mind turning your phone off/on and try sending a picture message to yourse...

ok, glad to hear it, I tried to refresh your profile, but I guess the issue is coming from the phone, since it works with a different application 🙂
Levis wrote:

Hi Michelle, would you mind turning your phone off/on and try sending a picture message to yourse...

I have no data plan on my Koodo phone but I want to receive incoming mms messages over WiFi. Is this possible because currently it does not work. I have a Samsung s6.
Userlevel 7
Badge +4
Levis wrote:

Hi Michelle, would you mind turning your phone off/on and try sending a picture message to yourse...

hi Claire,
MMS doesn't work on wifi. If you want to send MMS you need to enable mobile data. However, that might also enable unwanted mobile data usage. You could either buy an add-on data block ($2/month), or look around in the forum where there were some tricks to enable MMS without other data usage.
Levis wrote:

Hi Michelle, would you mind turning your phone off/on and try sending a picture message to yourse...

That's a shame. I get mms texts that am unable to open but I am on Wi-Fi. You think it would be the same thing. I only get 50 txts a month and it gets a bit old asking each sender to send again. Grrrr. I don't want any shape and form of data package. Thankyou !
Userlevel 7
Badge +4
Levis wrote:

Hi Michelle, would you mind turning your phone off/on and try sending a picture message to yourse...

Like mentioned above you can get the data block with MMS for $2/month. As well, if 50 texts aren't enough for you, you could upgrade to a new unlimited texting plan.
Userlevel 7
Badge +4
Levis wrote:

Hi Michelle, would you mind turning your phone off/on and try sending a picture message to yourse...

@Claire,
If you just want simple solutions, I would suggest you use third parties app for messaging over wifi like Facebook messager, viber, whatsapp...

Reply