Koodo Community

Community

Solved

Samsung Galaxy s4 won't stay connected to data


my phone won't stay connected to Koodo. It usually switches to emergency calls only. And then I have to go into settings to reconnect to the network any way to stop this? Its a Galaxy S4 the image shows what it does very frustrating .

8 replies

Userlevel 7
Hi Hilary, how is the coverage in your area? This is a link to a coverage map http://help.koodomobile.com/coverage-long-distance-and-travelling/coverage-maps
I live not far from the US border around the 95 area.
In New Brunswick... it wont attach the screen shot
it does it more when I am trying to text someone... If I'm not texting it will stay on Koodo which is weird and annoying
Userlevel 7
Have you tried manually selecting koodo/telus? Usually if you live near the US border, that's a good thing to do rather than have your phone search for carriers automatically.
Userlevel 7
Badge +4
Daniel Kim wrote:

Have you tried manually selecting koodo/telus? Usually if you live near the US border, that's a g...

Phone with post-paid SIM will pick up the strongest tower serviced by Koodo or authorized roaming partners, including US. Do you often get that annoying text message that tells you about marvellous US roaming near the border? That's courtesy of the CRTC. Folks in our area (near Qc 55 / US 91 border) get used to flipping the Network setting to [b]Koodo only to avoid accidental roaming if a US tower has a stronger signal than Koodo in our area.
Userlevel 7
Badge +4
Daniel Kim wrote:

Have you tried manually selecting koodo/telus? Usually if you live near the US border, that's a g...

You might also want to check signal strength. Bars on the phone are just barely decorations. Download from Google Play: https://play.google.com/store/apps/details?id=com.cls.networkwidget or something similar. Gives fairly instantaneous readings for voice and data in -dBm units. As long as you show less than 100 -dBm, you should be able to communicate. If you can send yourself a text and receive it promptly, then the network connection is working. Even in areas that have good coverage, it’s not uncommon to have dead zones. Stay away from large metallic objects such as wrought iron railings and open any metallic window blinds. Had a local problem with trees/hills/valleys galore at home in a rural area and was able to find a “hot spot” where everything works. Even re-orienting the phone while looking at the meter made a big difference. There are sister apps that will do the same for WiFi coverage as well.
Userlevel 7
Daniel Kim wrote:

Have you tried manually selecting koodo/telus? Usually if you live near the US border, that's a g...

Okay Bob, I know you're in the Estrie.

Stanstead? AC? Beebe? I'm in Magog Find me know FB, we should meet up.

Reply