Koodo Community

Community

Solved

Samsung Galaxy s4 not receiving messages on data


I have a Samsung galaxy s4. When I'm on wifi I receive all messages from all apps. When I'm not on wifi, turn data on, I only receive text messages. I don't receive Facebook messenger, what's app, viber, Skype, hangouts messages until I'm back on wifi. In settings I have background refresh turned on so the messages should be coming through.

13 replies

Userlevel 7
It sounds like you may have a data block on the account level. Log into self-serve and see if under your add-ons you have a data block. If so, you can modify your add-ons yourself to remove it from self-serve.
Thank you for the suggestion Ahmad. I checked my add ons and I don't see anything about a data block.
Userlevel 7
Badge +4
What version of Android are you running on your S4 exactly?
Paul.. 5.0.1
Userlevel 7
Badge +4
Delia wrote:

Paul.. 5.0.1

Go into your settings and make sure that under sounds and notifications that your phone isn't in do not disturb mode or that under app notifications that the apps that aren't notifying are not set to block notifications.
Delia wrote:

Paul.. 5.0.1

Thanks Paul. I checked all those and everything is set up how you mentioned it should be.
Userlevel 7
Badge +4
Delia wrote:

Paul.. 5.0.1

Ok go into your settings and click on data usage, tap on more in the top right corner and when the menu pops up make sure that background data isn't restricted. If it's not then tap on an app in that same data usage settings menu that isn't working and when it opens scroll down and make sure that it's not set to restrict background data for that specific app
Delia wrote:

Paul.. 5.0.1

Paul.. that is the first thing I actually checked when this problem started, so that's all set up right.
Userlevel 7
Delia wrote:

Paul.. 5.0.1

Pull down the notification shade and be sure mobile data AMD sync are turned on

In this example pic, data is on but sync isn't

If both are on open settings ... wireless and networks ... more... mobile networks.

Be sure "enable data" is checked

Also navigate to "Access Point Names"
be sure "Koodo.sp" is selected

In this example pic, data is on but sync isn't

Delia wrote:

Paul.. 5.0.1

Hi Chad.. I took a screenshot of my pull down window and there is no data option. I go to settings to turn data on. For this screenshot i had data and wifi on. I have done all the other things you suggested, they were already checked how you suggested.

Userlevel 7
Delia wrote:

Paul.. 5.0.1

Navigate to "Access Point Names" Create a new APN Enter the settings below: APN: sp.koodo.com Proxy: 74.49.0.18 Port: 80 Username: leave blank Password: leave blank Server: leave blank MMSC: http ://aliasredirect.net/proxy/koodo/mmsc MMS Proxy server: 74.49.0.18 MMS Port: 80 MCC: 302 MNC: 220 Authentication type: No set APN type: No set When you're done tap the menu key and save this apn Make sure it's then selected. See if that helps.
Delia wrote:

Paul.. 5.0.1

Hi Chad.. unfortunately that didn't work either. I tested it with Hangouts and Whatsapp and didn't get the messages until I was back on wifi.
Userlevel 7

Reply