Koodo Community

Samsung Galaxy S4 has stopped sending or receiving MMS via SMS - Tried Several Fixes - Any advice?

  • 22 August 2015
  • 8 replies

Hi folks, 

I have an unlocked Samsung S4 that I brought to Koodo.  All features worked perfectly on the previous network and for the first few weeks on Koodo, but now the phone won't send or receive MMS.  Have been reviewing threads on this community and elsewhere to no avail.  

[b]Additional background:

  • Samsung Galaxy S4 GT-i9500 running 4.4.2 (KitKat)
  • Is turned on.  
  • I can access the internet, send and receive non-MMS SMS messages, all through the Koodo network (e.g., not using wifi). 

I have been noodling with this quite a bit based on advice in other threads, with no success. 

Present configuration is:
  • Name: Koodo
  • APN: sp.koodo.com
  • Proxy: Not set
  • Port: Not set
  • Username: Not set
  • Password: Not set
  • Server: Not set
  • MMSC: http://aliasredirect.net/proxy/koodo/mmsc
  • Multimedia Message Proxy:
  • Multimedia Message Port: 80
  • MCC: 302
  • MNC: 220
  • Authentication type: Not set
  • APN type: *    (Note: I have tried "Not set", "mms", "default,mms" and "default,mms,supl" in place of the current setting of "*"
  • APN protocol: IPv4
  • APN roaming protocol: IPv4
  • Turn APN on/off: APN turned on
  • Bearer: unspecified
  • Mobilve virtual network operator type: None (*Note: there is a pull-down menu here that has the following options: "none", "SPN", "IMSI", and "GID")
  • Mobile network virtual operator: Not set
Steps taken so far (mostly on the advice of posters in this community - thanks!):
  • pulled SIM and battery
  • tried using a Telus APN rather than Koodo APN
  • Tried the various Koodo APN type settings listed above (e.g., Not set; mms; default,mms; default,mms,supl; etc)
  • Removed AVG security free app
  • Put in airplane mode and back to prompt phone to find its settings again
  • Cleared cache several times
  • Cleaned up system junk using Clean Master app (could this app be the culprit somehow?)
  • Downloaded Go SMS
  • Ran Root checker to make sure phone is properly rooted (it is)
  • Called Koodo customer service, where agent confirmed my APN coordinates and had me do another battery and SIM pull
The only difference after all this is in error messaging.  Before the steps taken above, when I sent an SMS with MMS, it appeared that the recipient had received the message.  Now, I get an error message that says "Message expired or not available" and, after several minutes, a red exclamation point icon notifying me of my failed MMS message.  When friends send me MMS messages, it appears on their phone to have reached me, but I receive no MMS nor any message that an MMS message has been sent to me.  
I should note as well that when, while in stock SMS system, I try to attach a picture, it instantly converts the file to an MMS file, so I dont' think it's an issue with the phone. 

Thanks in advance for any advice!!!


8 replies

Another quick note/update:
    I just did a factory reset Three APNs showed up automatically - two from overseas that I had previously deleted because the phone was defaulting back to them and adversely affecting connectivity, and the Telus APN for some reason (could the still-showing up overseas APNs be causing the issue somehow?) I added the Koodo APN per previous community posts Regular SMS messages can be received and sent perfectly MMS messages still not sent or received.  When sending, I no longer get any error messages or, later, the red exclamation point failure icon.  The MMS just sits there with the circular "sending" icon spinning below it, over and over and over again, all the live long day 🙂

And a few more updates:
    Downloaded and tried Textra.  No luck.  Outgoing MMS messages now show up as "sent" but are not received by the intended recipient. Went into Textra's MMS Settings and manually configured APN to http://aliasredirect.net/proxy/koodo/mmsc, and MMS Port: 80.  Same undesirable outcome.  Based on advice in another form, also tried sending MMS texts with Powersafe mode turned on and then off.  Neither had any effect.  Still not sending or receiving MMS messages. Textra marks them as "sent" but the intended recipient never receives them. Still not able to receive MMS messages either, although standard/SMS texts are still working perfectly, as is everything else (calls, internet, etc) on the Koodo network.  
Another update:
  • On advice on a similar issue in another forum, I edited my APN type to:  default,supl,mms,dun,fota*
  • The change above made no difference. 
Userlevel 7
Badge +4
Does this apply to you... http://www.sebertech.com/2013/07/at-galaxy-s4-cant-send-receive-mms-how.html

Hi Bob, 

Nope, I'm an Android user through and through, but thanks for the suggestion. 

A quick update: 
  • I can now send but not receive MMS messages
  • I am using the APN type outlined above
  • I have also installed Textra (popular SMS application on Google Play) and used some of the MMS-specific features on this app.   I have enabled Stagefright proection, MMS delivery reports and, under MMS settings, set a send size of 1MB, set "temporarily activiate mobile data when sending or receiving MMS (I'd read elsewhere that Koodo requires this), and also activated something called the T-Mobile WiFI Calling Fix, which temporarily disables wifi when sending or receiving an MMS message. 
So, yeah, I'm now able to send MMS, but I'm stil not receiving MMS messages, sadly.  Will continue to research solutions and will post my results here.  

Badge +4
I'm seeing a couple of third party messaging apps, (e.g. Go SMS Pro and Textra). It's best to uninstall the messaging app you no longer use to avoid any conflicts between the two third party apps. Configuring Textra as the default messaging app will prevent the app from interfering with your S4's stock SMS/MMS messaging app. You may have already done this, though worth mentioning in case someone else comes across a similar issue.

Personally, I would uninstall all of the third party messaging apps so that I'm only working with the S4's stock messaging features. I've been reading reviews for Textra and some users are complaining that the app has trouble sending/receiving MMS messages citing, "Can't send downloaded pictures. App lags. Won't receive picture texts and lags when it does." (complaint dated August 19, 2015).

Perhaps the mechanism that is supposed to temporarily activate mobile data when sending or receiving an MMS, is somehow flawed.

The developer(s) for Textra seem helpful, contacting them may be another option worth pursuing. I realize Stagefright protection is a feature of the Textra app. The same level of protection can be achieved from within the S4's stock messaging app by disabling auto-retrieve for MMS messages. Clean Master really hasn't given me too much trouble in the past, I prefer using CCleaner by Piriform instead.

The T-Mobile Wi-Fi Calling Fix could be interfering with the receipt of MMS messages. The cool factor about these third party SMS/MMS messaging apps is that MMS messages can be sent or received over Wi-Fi. Having a feature that disables Wi-Fi when sending or receiving an MMS message, defeats the purpose.
Thanks, Rikkster!  I've made Textra my default messaging app, as it's the only one with which I've had any success.  Go SMS Pro is long gone, as it failed to send or receive MMS successfully despite heaps of noodling and testing of its various MMS settings.
I am now using Textra and its advanced MMS settings, I am now consistently able to send MMS messages successfully.  I'm batting 100% in this regard, actually. 
However, I'm still not receiving any messages sent to me. Rikkster, I disabled Textra's T-Mobile Wifi Fix to test your theory.  Sadly, no change.  I'm still sending MMS successfully, but not receiving, so I guess I'll leave this feature disabled per your advice.
My plan is to test some of your other theories, rikkster, as well as a few others I've read about.  Specifically,
  • uninstalling Textra to see if I can at least replicate my current state (successful outgoing MMS; unsuccessful incoming MMS) using the stock messaging app;
  • if stock messaging app is still useless, reinstalling Textra and contacting the developers to see if they have ideas;
  • calling Koodo to have them "clear my switch" (Note: I have no idea what this means, nor did the Koodo CS rep I spoke with suggest it, but the CS rep's efforts were quite frankly hugely disappointing.  The CS rep basically re-confirmed my APN settings and, once confirmed, immediately concluded that my handset, which had been sending/receiving MMS the week before, was unable to send/receive MMS.  Geez, thanks!  Highly deductive!) 
Anyhow, I'll keep posting my successes and failures here. Thanks, Rikkster and Bob for some very helpful advice.

Badge +4
Thanks, Rikkster!  I've made Textra my default messaging app, as it's the only one with whic...You're welcome Andy. The correct term, refreshing the switch was a method used on CDMA devices. "Pulling the battery and sim card on an HSPA phone actually does the same thing that refreshing the switch used to do on CDMA; it gets the network to resend the updated connection information to the phone. What tech support can do, though, is check for errors in the SMS routing system and escalate a ticket to the network team if they can't make it work".

(The above topic goes back a few years and credit goes to Mobile Master Timo for providing this informative explanation).

Since you've mentioned earlier that SMS is in fact working, checking for errors in the SMS routing system would not apply to your situation. I've also noticed you have a device that has root access. Are you by any chance using a custom ROM?