Koodo Community

Community

Solved

Samsung Galaxy S3 (SGH-I747M) - LTE/4G Network Data not working


So I bought a used S3 about 3 weeks ago and I unlocked it with at a local shopping mall. I got my old contract on it and it worked perfectly fine until yesterday. I installed Cyanogenmod on it because a friend of mine recommended it for me. After having played around with the installed software (didn't encounter any problems whilst installing it) I decided that I liked the stock OS better so I downloaded the stock file (JellyBean 4.3) and I reinstalled my backup on the device but I am now having a big issue for me: I cannot seem to be able to active the Network Data, I use it a lot and it is really bugging me. I think I might have installed the "Telus" version of Android JellyBean 4.3 but remember reading that it was compatible with Koodo Mobile and their networks. Help?

22 replies

Userlevel 7
Do you have the correct APN settings in the phone?
After some research I realized that I had to add one since it only gave me two Telus APNs by default. These are my settings:

Userlevel 7
Proxy is incorrect. Make sure these are what you have in your phone and try again: Name: Koodo SP APN: sp.koodo.com Proxy server: 74.49.0.18 Port: 80 Username: Password: Server: MMSC: http://aliasredirect.net/proxy/koodo/mmsc Proxy server: 74.49.0.18 Port: 80 MCC : 302 MNC : 220 APN type: default,mms,supl
Jonathan I wrote:

Proxy is incorrect. Make sure these are what you have in your phone and try again: Name: Koodo...

This helped me with an LG G3, thanks!
Wow! Thanks a lot it fixed my problem! One question thought: I used to have "LTE" icon for connection and now I see a "4G" icon instead. I heard that they are the same but I just want to make sure. And if not does it just vary from where I am? As I heard some regions don't necesseraly get for example 4G connection but only 3G. Thanks in advance!
Userlevel 7
Samuel L. wrote:

Wow! Thanks a lot it fixed my problem! One question thought: I used to have "LTE" icon for con...

Yup, some areas don't have LTE yet... But if you were getting it before and now you don't, just do me a favor and check your network settings. You have to make sure it says WCDMA/HSPA/LTE. I'm pretty sure I gave you the APN type needed to get LTE as I had this issue with my Koodo S4 mini using it with my Telus plan so just wait it out a little bit.
Samuel L. wrote:

Wow! Thanks a lot it fixed my problem! One question thought: I used to have "LTE" icon for con...

I read a bit around the webs and learned that 4G is basically the same thing as LTE (with some minor differences). And yes my WCDMA/HSPA/LTE setting is checked, therefore I'm guessing the stock OS that I installed shows "4G" instead of "LTE".
Userlevel 7
Samuel L. wrote:

Wow! Thanks a lot it fixed my problem! One question thought: I used to have "LTE" icon for con...

It's possible, but phones will usually display 4G and LTE as separate things.
Samuel L. wrote:

Wow! Thanks a lot it fixed my problem! One question thought: I used to have "LTE" icon for con...

Maybe there is another Proxy server for LTE? I don't know, just guessing...
Userlevel 7
Samuel L. wrote:

Wow! Thanks a lot it fixed my problem! One question thought: I used to have "LTE" icon for con...

Nah, it's the same one. I think it's the APN type. Try putting in blank and see what happens, then look at this and see if I was right, because this worked for the S4 mini I had on Telus (same network as Koodo) http://forum.xda-developers.com/showpost.php?p=34375750&postcount=5
Samuel L. wrote:

Wow! Thanks a lot it fixed my problem! One question thought: I used to have "LTE" icon for con...

I have the samsung galaxy s 3 and i get 4g and sometimes it shows Lte as well, maybe where i am from time to time, butno difference.
Samuel L. wrote:

Wow! Thanks a lot it fixed my problem! One question thought: I used to have "LTE" icon for con...

If I leave the APN type blank, 4G still appears, sometimes drops down to 3G and H+.. I also tried "Internet + MMS" and "internet + mms" these two would not work. I have also attempted "default, mms" and "default, mms, suppl" and these two were varying between 3G, H+ and sometime goes up to 4G. Overall my observation are that for my phone, "default, mms", "default, mms, suppl" and a blank APN type work and I'm guessing that they will all work with 4G and LTE and that I simply need to be in a LTE-enabled zone. P.S.: What is H+? Never seen this before!?
Userlevel 7
Samuel L. wrote:

Wow! Thanks a lot it fixed my problem! One question thought: I used to have "LTE" icon for con...

H+ is up to 42 mbps.
Samuel L. wrote:

Wow! Thanks a lot it fixed my problem! One question thought: I used to have "LTE" icon for con...

thanks!
Samuel L. wrote:

Wow! Thanks a lot it fixed my problem! One question thought: I used to have "LTE" icon for con...

how can i active 3g connection in this phone?
Samuel L. wrote:

Wow! Thanks a lot it fixed my problem! One question thought: I used to have "LTE" icon for con...

sgh-i747
Samuel L. wrote:

Wow! Thanks a lot it fixed my problem! One question thought: I used to have "LTE" icon for con...

My s3 can only get edge connection. Any idea how to get lte or just the H connection?
*#272*Phones IMEI Here# <<-- Csc Sales Code here u fix dial from phone
I have s3 i747 in pakistan its 3g is not working plz anyone help me
Userlevel 7
Badge +4
Muhammad Naeem wrote:

I have s3 i747 in pakistan its 3g is not working plz anyone help me

If it's a Koodo phone, you have to enable Pay per use International Roaming for anything to work there at all. You can do it on self serve, or *611.
So I Just went through this, and I can get 4G (and LTE) now. But it still doesn't seem to want to let me do MMSes. Any thoughts?
Hi there, I just got a Koodo plan and I have the exact same problem as Dan - MMS'es don't work. Data works (same phone). What is going on?

Reply