Koodo Community
Question

Samsung Galaxy Ace II X Picture Messaging Issue

  • 23 January 2013
  • 66 replies
  • 150 views

I've been having trouble with picture messaging. I have the Samsung Galaxy Ace II X and the 15 dollar plan plus unlimited messaging add-on. How come whenever someone sends me a picture and I click the download button I could literally be waiting for hours for it to download yet it never does? Is it because my data is turned off?

This topic has been closed for comments

66 replies

Userlevel 2
That's exactly why. Mobile Data is required for picture messaging to work. Unlimited Messaging just removes the overage charge for sending texts & picture messages. Keep in mind with Mobile Data turn on, any applications running in the background that requires Mobile Data for use will use data and data charges will be applied. To minimize these without a data plan, if you are at home, turn on your wifi connection. Your wifi connection will take priority as the main data connection for your apps, leaving the Mobile Data connection for just pictures. If you don't have a wifi connection & depending on your rate plan, you may need a data plan to keep data costs low.
Userlevel 7
Badge +4
If you search these messages there are a few examples of how to add apns to allow pic messaging only. The stock rom wont allow you to delete the koodo apn so you'll need to create two new ones.
Userlevel 7
Badge +4
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireless controls / Mobile networks / access point names You'll be creating two APN's Add the first apn (usually by hitting the menu key and tapping ADD NEW) Note: in the example below please omit the spaces between the http: and the address This is done because some websites shorten URL's Input the following settings (leaving designated fields blank): APN NAME: Koodo (NoData) APN: sp.koodo.com Proxy server: Port: Username: Password: Server: MMSC: Proxy server: Port: MCC : MNC : APN type :internet Save this entry (usually by hitting the menu key and selecting SAVE) Now create a Second APN using the following settings APN Name: Koodo MMS ALLOW APN: sp.koodo.com Proxy server: 74.49.0.18 Port: 80 Username: Password: Server: MMSC: http: //aliasredirect.net/proxy/koodo/mmsc Proxy server: 74.49.0.18 Port: 80 MCC : 302 MNC : 220 APN type :mms Now save this entry as you did the first. On the list of available Access Point Names you'll notice three (or more) entries. Select the Koodo (NoDATA) apn and make it active (you'll notice you can not choose the Koodo MMS ALLOW entry) Exit the APN menu. You'll notice the 3G or 4G data indicator has disapeard leaving only the Signal strength indicator. When you do send a picture the Data indicator will re-appear and the picture should be sent. Same when you get a picture message.
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...I followed all these steps. When you send/receive pictures will you have to manually turn off wifi or will it be done automatically? Also, by doing this and selecting the "Koodo (NoData)" apn does this mean I won't be charged for any data at all? I have unlimited picture messaging included in my plan and don't want to be charged for any additional data, since my parents actually pay my bill.
Userlevel 7
Badge +4
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...Everything should happen automatically.data will come on whenever a picture is sent or received. After the function is completed the data connection is terminated. Other than pic msgs, data will not function and there SHOULD be no charges. Easy way to tell is to run an app that requires data with wifi off (like the browser) no way it should work.
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...I turned the wifi off for a few seconds and it automatically turned 4G on and used about 60kb of data 😕 so I guess it didn't quite work to disable data for everything but mms
Userlevel 7
Badge +4
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...Make sure the koodo (nodata) apn is actually selected. If its possible, delete the original koodo apn. This did work for me on my s2x I'm surprised it didnt for you. You may also wish to reboot after selecting the apn. Just make sure to check that it's still connected to koodo (nodata)
Userlevel 7
Badge +4
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...You can also try adding a false proxy ip to the nodata apn. Like 77.88.9.77 see if that solves the issue
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...The Koodo (nodata) apn is selected but I just noticed that for this apn some fields were filled automatically "MCC:302" and "MNC:220". I didn;t even notice this but when I looked at your directions again and compared to mine I noticed the discrepancy. Is this the problem?
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...It wont let me leave these fields blank though
Userlevel 7
Badge +4
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...As long as the type is internet it should be ok
Userlevel 7
Badge +4
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...mcc: mobile country code, mnc: mobile network code. basically these tell the phone that the country is Canada and the carrier is Koodo. they won't enable data use by themselves.
Userlevel 7
Badge +4
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...Im actually surprised it didn't work for you. You could also try changing the apn to spp.koodo.com
Userlevel 7
Badge +4
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...Could it also be your phone is downloading or sending waiting pictures?
Userlevel 7
Badge +4
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...also, the phone will count pictures as data use, Koodo won't. test the internet connection. if it won't load when wifi is disconnected then the trick is working.
Userlevel 7
Badge +4
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...Thanks Timo 🙂
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...Nope still not working 😕 it turns 4G on as soon as I turn off wifi. In the "data usage" section of my wireless and network settings it gives me the option to "restrict background data" should I select this option to avoid being charged for excess data? Sorry for all the questions, I'm technologically challenged.
Userlevel 7
Badge +4
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...before you do check to see if your browser works. I have a feeling your phone is sending pictures out
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...I tried sending 2 pictures last week, neither of them sent so i'm guessing that is whats going on. What should I do in this case? I turned my wifi back on because I was scared of eating up data. The browser still works when wifi is off though. and the data usage section tells me that there were certain apps (internet, google services, facebook, etc.) that each used about 25 kb of data.
Userlevel 7
Badge +4
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...If your browser still works with wifi off then the method used is not working. You should try your browser & it will say it can't connect or needs data connection.
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...I think this method is working now because the 4G no longer connects with wifi off and when I try the browser it says "no network connection...cannot connect to the internet" etc etc so that's perfect!! Now the only issue is whether or not my picture messaging will actually work since I haven't tried it yet, but I'm glad this data issue is taken care of!
Userlevel 7
Badge +4
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...Try sending yourself a picture.
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...Yup works! Thanks for all the help boys 🙂
Userlevel 7
Badge +4
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...Did you need to change anything from the original trick? Tell me so i can modify the text file
Userlevel 7
Badge +4
Setting up A Koodo phone for MMS with no additional Data Access Navigate to Settings / Wireles...i should mention much of the credit for this workaround goes to John Burke