Koodo Community

Community

Solved

S7 Edge incoming/outgoing calls not working most of the time after Nougat update


Anyone have this issue? After the update, my incoming/outgoing is completely stalled. For outgoing, tries to connect, and just drops after about 20 secs. Same for incoming, friend tried calling and hears nothing and just drops. I have to do a restart, then it works for a while, but I'll notice a few hours later, same issue (either friend tries to call me and messages me saying he can't connect or I can't make outgoing). I have to do like 3 restarts a day. This is happening while at work, at home, and even another city I visited, so it's definitely not geo related.

22 replies

Userlevel 7
Badge +4
Hello RL,

When this happens, do you have service or you have absolutely none?
I have full service/bars. I've been downtown TO, uptown, suburbs - all areas where coverage is never an issue. 
Badge +4
Try a network reset. Go to: Settings > Backup and reset - scroll down to and tap Reset network settings and follow the prompts.

After an update and as a last resort, it is recommended to perform a factory reset particularly when you're experiencing problems with the phones' functionality. [b]Note that this procedure wipes all user content from the phone. I prefer the second method shown in the video below, however both methods accomplish the same task. 

https://www.youtube.com/watch?v=BxJis11Ze3U
I'm experiencing the exact same issues as well. I've tried everything, except for factory reset and I really don't wanna do that.....the most annoying thing is that when this happens, data will still be working, just no phone calls (in or out), so I will have no ideas that my phone is dead and I'm out of reach......
Userlevel 7
Badge +4
That's very weird. Does it say something when you try calling? Or it's doesn't connect?
Robert wrote:

That's very weird. Does it say something when you try calling? Or it's doesn't connect?

It just doesn't connect, stuck on the dialer screen, no tone....I've read on various sites and forums that many other people on different carriers are also experiencing the same issue; however, it doesn't seem to be very widespread.......some reported that factory reset won't help that's why I haven't tried it yet....as soon as the next Pixel comes out I will ditch my S7 and will never touch Samsung phones again.
Robert wrote:

That's very weird. Does it say something when you try calling? Or it's doesn't connect?

I have the absolute exact issue with my s7 edge. Problem started after Nougat update. I am on Telus network. This is driving me nuts. I keep missing important phone calls. A reboot temporarily fixes the issue. I have tried wiping cache partition, resetting network settings, resetting phone settings.....to no avail. The only thing I have not tried is factory reset. PLEASE HELP
Userlevel 7
Badge +4
Robert wrote:

That's very weird. Does it say something when you try calling? Or it's doesn't connect?

Try factory resetting your phone?

Although it seems more like a phone problem, you could take your sim card to a Koodo store and get them to test it for you or if you have another phone you can use/borrow you can test it yourself.
Robert wrote:

That's very weird. Does it say something when you try calling? Or it's doesn't connect?

It's definitely not a SIM card problem and users on other forums all over the world have been reporting the same issues. Many of them reported factory reset won't solve the problem. A co-worker of mine just got a brand new S7 from Bell, same issue. I just got back from a vacation, same issue with a brand new foreign sim card, connection will drops randomly and a reboot will fix it.

This is 100% a software issue. The problem is it's completely random and extremely hard to diagnose. Sometimes it can go 2 or 3 days without a problem, and out of the blue it just stops getting phone calls.....Besides, it will be hard to show the problem in the store 'cause a simple reboot will temporarily fix the issue.
Userlevel 7
Badge +4
Robert wrote:

That's very weird. Does it say something when you try calling? Or it's doesn't connect?

And, of course, showing in store isn't going to resolve the issue anyway, for, as you described, it appears to be a widespread software issue, and Samsung's issue to address.
Userlevel 3
Robert wrote:

That's very weird. Does it say something when you try calling? Or it's doesn't connect?

Nothing is going to fix this issue except a proper software update from Samsung. I also have this issue. Stuck on dialler screen, incoming call goes straight to voicemail. My last Samsung phone.
I tried factory reset, turning Airplane mode on and off, nothing works except restarting the phone after the issue.
Userlevel 3
Robert wrote:

That's very weird. Does it say something when you try calling? Or it's doesn't connect?

Is the issue on both S7 and S7 Edge or only S7 Edge?
Userlevel 3
Robert wrote:

That's very weird. Does it say something when you try calling? Or it's doesn't connect?

I have a S7 with this issue so both.
Userlevel 3
Robert wrote:

That's very weird. Does it say something when you try calling? Or it's doesn't connect?

Then I should return the one I got this week... It seems they haven't fixed this in over a month -I wonder if anyone at Koodo or Samsung cares about the issue at all.
Userlevel 7
Badge +4
Robert wrote:

That's very weird. Does it say something when you try calling? Or it's doesn't connect?

It's not really Koodo's to fix, as the issue is occurring on all carriers!

Robert wrote:

That's very weird. Does it say something when you try calling? Or it's doesn't connect?

Would you say this is A Samsung issue? My phone is useless right now. I can't trust it. Don't know when I'm missing calls. I have to try to dial out and if it's not dialing out, then I know the incoming calls is not working. Data otherwise works fine. My WhatsApp messages are ok.
Userlevel 6
Robert wrote:

That's very weird. Does it say something when you try calling? Or it's doesn't connect?

It's an issue with Samsung's software. As every carrier in Canada uses the same software (it's multi CSC), the issue affects every carrier. I would assume that Samsung is aware of the issue, and is theoretically working on a fix. I know Samsung's update track record is horrid, but being this issue basically breaks the phones, they will fix it. It's just a matter of when.....
Robert wrote:

That's very weird. Does it say something when you try calling? Or it's doesn't connect?

ok.  i'm going to try factory reset as a last resort to see if this helps at all.....will let you guys know
Robert wrote:

That's very weird. Does it say something when you try calling? Or it's doesn't connect?

Ok everyone. Here is my update, 1 week after factory reset. It looks like the issue is resolved! There are some key observations to note here though: -i didn't use any Samsung or other software to back up data or apps. I manually backed up my data via USB connection to PC -i used the factory reset option in settings -after the factory reset, my phone downloaded an update... Which was unusual because I was not notified of any pending updates before the factory reset -i should have noted my build number before the reset..... But here is my build number after the reset: Android 7.0. Build Nrdm90m.g935w8vlu2bqe5 Cheers
Robert wrote:

That's very weird. Does it say something when you try calling? Or it's doesn't connect?

I suspect that BQE5 update is the key. I did a factory reset last Friday, didn't receive the update, still stuck at BQB6, didn't use any backup software either, didn't use any mod, the problem is still there.
According to SamMobile, BQE5 build is quite new, and hasn't been released on Koodo yet, are you with Rogers/Fido by any chance?
Robert wrote:

That's very weird. Does it say something when you try calling? Or it's doesn't connect?

I'm with Telus
Robert wrote:

That's very weird. Does it say something when you try calling? Or it's doesn't connect?

I just received BQE5 update this morning (on Koodo), keeping my fingers crossed....

Reply