Koodo Community

Community

Solved

S3 No SIM Card error


After a few months of trouble free use, my S3 is giving me 'No SIM Card' errors and forcing a restart. This is happening up to a dozen times a day. Very frustrating. The phone is unrooted. I've just tried a factory reset and still got the same error. The only solutions I've found online involve rooting the phone. Doing a quick search shows that this is happening to others as well. I have to drive a ways to the nearest Koodo Kiosk so I won't be able to do that until the weekend. Does anyone have any ideas?

3 replies

Userlevel 7
I can't help with this but I just wanted to mention that whatever you do, make sure not to root the phone or it will void your warranty and your trip this weekend will be pointless. Hope others are able to help you and fix your problem. Good luck!
Userlevel 7
Badge +4
Have you updated the software to Android 4.1 Jelly Bean yet?
Userlevel 2
Hey Vern! Have you tried with another Sim card? Maybe your Sim card is defective. You can also try to insert a little peace of paper along with the Sim card in the slot, so that the sim card stays sturdy. If you still get the error message, call 1-866-995-6636 (option #6) from a landline in order to have your phone available for a complete troubleshooting. I hope this helps.

Reply