Koodo Community

Community

Solved

Rooting First Gen (2013) Moto G


Hello,

I own a first generation Moto G (2013 - XT1032) which I unlocked and rooted back in 2014 by following the steps outlined here: http://www.modaco.com/forums/topic/366771-root-your-moto-g-option-1-superboot/?page=1

I remember thinking the process didn't work originally but it was a matter of restoring wifi which allowed the phone to download/install SuperSU (at least that's my understanding).

Earlier this year I re-locked/unrooted the phone so that I could install Lollipop 5.1 (and thanks again to rikkster for all his guidance)!

I've decided to unlock and re-root the phone one final time and desperately need help successfully re-rooting. The unlocking was successful but after multiple attempts I have been unable to root/re-root my phone. I have tried the old steps (link above), as well as Chainfire Auto Root and TWRP procedures - all to no avail.

The old steps produced a "no command" message (with robot icon) upon reboot, the Chainfire/root-windows command just appeared to "hang," and I received a "cannot open" error when attempting to flash a recovery .img file.

Based on my reading, I'm unsure if running command prompts from my PC as administrator is crucial. I can also foresee issues pertaining to downloading the proper tools (e.g. SDK, etc.).

Basically, I don't  have a firm grasp on what it is I should do to make rooting work once again - I would greatly appreciate any advice anyone can offer. A clear step-by-step guide would be awesome!

Thanks in advance!

5 replies

Userlevel 7
Badge +4
The website XDA Developers is you best friend when it comes to this stuff, that and YouTube.
Badge +4
Hey Chad, Unfortunately, I don't have my Moto G 1st. gen to be able to troubleshoot alongside with you. I've used auto-root applications in the past and didn't like them and instead used ADB and mfastboot. Google 'standalone SDK tools'. You don't need to download the entire Android SDK. I did however save the mfastboot flash and erase commands. http://droider.eu/2014/12/10/android-sdk-stand-alone-tools/ You can flash these commands in batch, they don't have to be entered singularly. I do recall right-clicking on the command prompt application and selecting 'run as administrator'. Shift + right click in the platform-tools directory will invoke the command window in the platform-tools directory. See: mfastboot download http://mark.cdmaforums.com/ADB.htm mfastboot flash partition gpt.bin mfastboot flash motoboot motoboot.img mfastboot flash logo logo.bin mfastboot flash boot boot.img mfastboot flash recovery recovery.img mfastboot flash system system.img_sparsechunk.0 mfastboot flash system system.img_sparsechunk.1 mfastboot flash system system.img_sparsechunk.2 mfastboot flash modem NON-HLOS.bin mfastboot erase modemst1 mfastboot erase modemst2 mfastboot flash fsg fsg.mbn mfastboot erase cache mfastboot erase userdata mfastboot reboot http://forum.xda-developers.com/moto-g/Root
Hi Paul and Rikkster,

I really appreciate the prompt responses. I took a closer look through the comments on XDA-Developers and was able to complete the rooting process.

In case someone else encounters the same difficulty I had (and apparently others have faced), here's the process I followed (and solution):

1. I followed the directions outlined here (but downloaded the appropriate files for my XT1032):

http://forum.xda-developers.com/moto-g/help/guide-root-xt1032-xt1033-moto-g-running-t2965507

This process was unsuccessful.

2. I noted the following comment located here however: 

http://forum.xda-developers.com/moto-g/help/guide-root-xt1032-xt1033-moto-g-running-t2965507/page9

"If you're already OEM unlocked, just open a command line in the image folder and run fastboot boot CF-Auto-Root-falconumts-falconreteu-xt1032.img, it'll root the phone."

3. Once I followed this advice and executed the command above, the phone switched to a screen with a red droid with scrolling white text and eventually rebooted to the main screen - and with that (after my apps optimized) my phone was rooted!

Thanks again and I hope this helps others!
Userlevel 7
Badge +4
Chad Wick wrote:

Hi Paul and Rikkster,

I really appreciate the prompt responses. I took a closer look through the...

Awesome glad it worked out for you, have a great one and feel free to return if you need any further guidance with any issues.
Badge +4
Chad Wick wrote:

Hi Paul and Rikkster,

I really appreciate the prompt responses. I took a closer look through the...

Simple enough fix, glad it's working.

Reply