Koodo Community

Community

Solved

Roaming


I arrived to Italy a few hours ago and still my Motorola moto g4 can't connect to any Italian networks and keep saying "emergency calls only". Do you guys know what's going on?

7 replies

Userlevel 7
Badge +4
Go into networks and go into manual selection and let the list populate after 1-2 minutes. What do you see? Hav you restarted your phone yet?
Yeah I did everything you said, but everytime I try to connect to one of these networks it says impossible and will try later. I also restarted my phone a couple of times.
Userlevel 7
Badge +4
Oh also did you enable international roaming with the zero dollar add-ons in self-serve ? You need those on in order to roam internationally. Pay-per-use international long distances international voice roaming, and International Data Roaming for data. Also I'd suggest picking up a local Sim as it's almost always significantly cheaper.
How do you enable that zero dollar add one? On my personal Koodo page? And yes I've already a local sim cause I'm actually from Italy (I live in Canada though) but I still need to roam for some business purposes. Thank you so much for your help
Userlevel 7
Badge +4
Hello Gabriele.

Here's how to add the free international roaming packages. There's two of them : 

Connect to sell serve and go to your add-ons



Click to change the add-ons



Search for 1) International Voice Roaming and 2) International Data Roaming



Userlevel 7
Badge +4
Another option, although I don't know if it needs to specifically be your current number for business purposes is to use Fongo or Textnow where you will receive a Canadian phone number and you can make free calls over cellular data or wi-fi. Fongo says their bitrate is 2 minutes per MB.
Userlevel 7
Badge +4
@Gabriele You account has all the right services, including the zero dollar add-ons. I'm thinking it's your phone and may be restarting would help as long as roming is turned on in your phone's settings. 

Reply