Koodo Community

Community

Solved

PokemonGo works on wifi, but not on my data plan


Userlevel 3
Hello,

I have a problem with logging on the game PokemonGo, and I wonder if other Koodo users have encountered this issue. PokemonGo works on wifi, but not on my data plan.

For the last week, when I'm using data, I cannot log into my account when starting the game. I have been trying at different times of the day, every day for the last week. The moment I turn on wi-fi, I can log in fine and the game works.

I can even log in at home (wi-fi), turn the wi-fi off, and go walk about town getting data from Niantic's servers. The moment I switch applications, though, PokemonGo boots up again and I can get to my account.

It started with Niantic releasing version 0.37.0 (the buddy system one, ~2016-09-12), in which they are prohibiting rooted devices from playing. Maybe it's connected to my problem?

Anyway, just wondering if I alone am experiencing this or if Koodo data is somehow distrusted by Niantic.

Thanks for taking the time.
Have a great weekend.

100 replies

Userlevel 7
Badge +4
Hi Thierry.

I am sure it has nothing to do with Koodo's data. Mine works fine but I do not have a rooted phone tho
Userlevel 7
Badge +4
Robert wrote:

Hi Thierry.

I am sure it has nothing to do with Koodo's data. Mine works fine but I do not have ...

Mines working as well just fine.
Userlevel 2
I'm with Koodo too and play Pokemon Go quite regularly when I'm using my Koodo data and I can confirm that it works fine over 3G and LTE as well as over WiFi. The only possible reasons I can think of as to why you aren't able to play the game when using a cellular data connection could be if the data connection in your current area isn't stable enough or if you accidentally turned off your cellular data and forgot to turn it back on. I don't think it has anything to do with the game's version or update to the game. You can check if you have cellular data enabled by going into your phone's settings and check your network settings from there. I'm not sure if you're using an Android phone or an iPhone but you may also want to make sure your phone isn't rooted (in the case of Android) or jailbroken (iPhone).
Userlevel 3
DanielLui1 wrote:

I'm with Koodo too and play Pokemon Go quite regularly when I'm using my Koodo data and I can c...

Thank you for the extensive response. My android can switch between providers, so I had it "unlocked", but that's all. It's running 5.1.1

Knowing now that Koodo is unrelated to this issue, I will go to Niantic, I guess.
It's been a week since any updates on this thread but I'm having the issue now too, and so are a few other people I know who are with Koodo.
Userlevel 7
Badge +4
Jacob Bugeja wrote:

It's been a week since any updates on this thread but I'm having the issue now too, and so are a ...

I've had it happen one time, I rebooted and that was it. If you start on wifi, and then wonder off and it connects to your data, it usually freezes up and won't allow you to play. I found if I turn off my wifi beforehand, I have no issues.
Userlevel 3
Jacob Bugeja wrote:

It's been a week since any updates on this thread but I'm having the issue now too, and so are a ...

@Jacob Thanks for the info. I still have the issue. I opened a ticket with Niantic. I will update this topic when progress is made.
Jacob Bugeja wrote:

It's been a week since any updates on this thread but I'm having the issue now too, and so are a ...

Hey Thierry, sounds like your original issue was that you need to reset your app permissions. it unrestricts all background data as Pokemon go requires access to Android services, Google play Store, among others. I had the same issue at about the same time as you and resolved it with a app permissions reset. Currently the issue is now on any telus or telus subsidiary like koodo. It is only impacting those in Ontario. All we can do is send it our complaints to koodo and wait for them to resolve it on their end.
Userlevel 3
Jacob Bugeja wrote:

It's been a week since any updates on this thread but I'm having the issue now too, and so are a ...

Good news:
I don't know how to reset permissions so
- I uninstalled the app + reinstalled,
- I made sure Google Play Store, Services Google Play and Maps had background network access.
- I started with only mobile data and gps enabled, not wifi.

I worked twice this morning.
Userlevel 3
Jacob Bugeja wrote:

It's been a week since any updates on this thread but I'm having the issue now too, and so are a ...

:( Same issue as before happened a few hours later, without any changes to the permissions.
Many people I know are having this issue, not only those with Koodo but with Telus and Public Mobile as well. It does not seem to be an issue caused by the mobile device itself. I have an S7, my gf has a Sony z3, my friend has a one plus and it goes on...

What is interesting is that if I connect to a VPN on my phone, then Pokemon Go will load normally using mobile data. I wonder what that could mean..

Hope Telus/Koodo fixes this soon..
Same boat here. Very frustrating. Hope this gets fixed soon
same issue for me too, started yesterday, wont boot up over lte
Hi Thierry, 

I've been having the same issue for the past week or so. I've noticed that my data still works fine with other apps, like my internet browser and snapchat. I've also noticed that it isn't just booting either. I can't play at all if I go from wifi, to data. And it also works if you're tethered to someone else's phone. Really frustrating. Please update here if you're able to resolve the issue with Niantic. I will try as well 

Good luck! 
Userlevel 2
From my experience, if you're in an area where the cellular signal isn't great, it will give you the impression that the game isn't loading over your data connection. In those instances, try leaving you're cellular data connection turned on and also connect to a reliable free WiFi hotspot that's available in your current location. After doing so, restart the game and most of the time it will work after enabling WiFi as well.
I'm agreeing that the problem is not on Koodo/Telus's end because other applications work on data fine. I also agree that this isn't device oriented. It's most likely on Niantic's end; who knows where the problem originates specifically, maybe it's somewhere in the exchange of data from their servers to the client (the users) or maybe there is something in Koodo/Telus they mistrust. Either way, it doesn't look good on any of them from the player's perspective.

What I find most strange is that this problem began for the original poster about 2 weeks ago, and ever since more and more users are starting to experience or continue to have this exact same issue. It's strange how we all got hit by it, but only gradually instead of all at once.

For me, the app will not load any data at all if I walk away from WiFi range and switch to Data connection (LTE+). [b]Simply put, Pokemon Go does not work on Data for me. It defeats the purpose of an app that wants you to explore the world around you. But everything else that uses Google Accounts or doesn't works fine in Data. And no, it's not a bad cellular signal either. I'm on a University campus in the center of a city. And yes, I understand we can use tethering hotspots, but again, that defeats the purpose of an app that wants you to go outside.

I have tried;
- Resetting my phone
- Force Stop and Clearing the apps cache
- Uninstalling the App and installing it again
- Turning on "Developer Mode" > "Aggressive Data switch"
- Turning on "Allow Less Secure Apps" on Google's end
- Turning off "Restrict Background Data"
- As a last resort, I factory reset my phone (I backed up everything important before).

But nothing works.

I also sent a detailed report to Niantic with everything I tried above. I will continue to stay in touch through here. Hoping to hear something soon! It would be reassuring to hear that someone is working to find a solution, whether it be in Koodo/Telus's end or Niantic's.
David Cosman wrote:

I'm agreeing that the problem is not on Koodo/Telus's end because other applications work on data...

I have been down for 5 days now. Same thing- won't work on data.
I'll add my name to the not working list. I have been out since i downloaded the update yesterday morning. I'm on Koodo using a s4
Same here. Out since yesterday on telus
Userlevel 7
Badge +4
My brother on rogers and sister on bell both are having this issue as well. Not sure it's a Telus/Koodo issue.
Chadwick wrote:

My brother on rogers and sister on bell both are having this issue as well. Not sure it's a Telus...

There's an additional issue since the newer updates were the app doesn't work if they've restricted background data on certain things like Google play Store, Android services, etc. As the app requires those. See if the issue for them is resolved of they reset their app permissions. As for us this seems like a telus and subsidiary issue in Ontario only.
Same issue, I'm with Koodo and have a Galaxy S4. I've been out since yesterday. A lot of people on my local Pokemon Go Facebook group are having the same issue and are relating it back to Koodo/Telus. I also tried every fix possible from Google with no luck. Some people are finding it works if they switch from LTE to 3g or 4g but that's not working for me either. However it works for them so I believe it has to do with the network.
Same as above. Wish I checked here before factory reset, which was slightly inconvenient but I've tried several things suggested on other records but still won't work without Wi-Fi. Also with Koodo, and the problem began sometime this week. Very very rarely it manages to connect over a data connection, but mostly it doesn't.
Userlevel 6
Hey everyone! Confirming that there is a known issue in Ontario right now...customers are not able to access Pokemon Go over 4g/LTE.  The technical support team is investigating further in order to fix the issue as soon as possible. Thanks for your patience!

EDIT: Issue resolved!
Melissa wrote:

Hey everyone! Confirming that there is a known issue in Ontario right now...customers are not abl...

Thank you for the update!

Reply