Koodo Community
Solved

Pixel 3 - VoLTE and Wi-Fi Calling not working

  • 13 February 2019
  • 7 replies
  • 1692 views

I have a Google Pixel 3 which is unlocked from another carrier, and I'm using it with my Koodo SIM card.
VoLTE shows as being provisioned and turned on, yet when I make a call, data drops back to H+ even though I'm in a strong signal LTE+ area.
Can anyone assist?
icon

Best answer by Dinh 13 February 2019, 04:35

That wasn't a VoLTE provision.

You need the "VoLTE access" add-on in your selfservice. If you didn't see it, you need to contact Koodo directly and ask an agent to add it for you. Send a message to their facebook (https://www.facebook.com/Koodo)would do.

Also, was the error showed up when you tried to activate VoWi-Fi?, you need to contact Koodo directly anyway to ask them.
View original

7 replies

Userlevel 7
Badge +4
hi,
When you said "VoLTE being provisioned", you meant you had VoLTE access in your self service?

Also, did you enable VoWi-Fi option in your phone settings?

Noted that: in their official VoLTE and VoWIfi support page, Pixel 3 wasn't on the list. However, in their product page, Koodo list VoLTE and VoWIFI for that device.

https://www.koodomobile.com/help/voLTE
https://www.koodomobile.com/help/wifi-calling
Here's where I see VoLTE:


I don't see any mention of VoLTE in Self-Service - where would I look for that?

When I try to enable WiFi Calling, I just get stuck in a loop. I receive the SMS code, which I enter to verify my account, but I just end up here every time:

Userlevel 7
Badge +4
That wasn't a VoLTE provision.

You need the "VoLTE access" add-on in your selfservice. If you didn't see it, you need to contact Koodo directly and ask an agent to add it for you. Send a message to their facebook (https://www.facebook.com/Koodo)would do.

Also, was the error showed up when you tried to activate VoWi-Fi?, you need to contact Koodo directly anyway to ask them.
Userlevel 7
Badge +4
Do as the error page says and contact Koodo at the number provided. (Or through Facebook (https://m.me/Koodo))
Thanks. I contacted them through FB and had the agent add it. Will try out VoLTE now and report back.

Bingo! That worked. VoLTE and Wi-Fi calling are now working on my Pixel 3. Thanks Dinh.
Userlevel 1
Thanks for the advice! I tried the same thing--asking Koodo on Facebook to enable VoLTE for me. The problem is, I told them which model of phone I have, and they said it isn't supported. So I talked to them on the phone another day, didn't mention which model of phone I have (they didn't ask), and now Voice over LTE is working! I'm one of the many people all over the world having call quality issues on the Pixel 3, so we'll see if this resolves that. No problems so far, but haven't made any calls from locations that are frequently bad.

Reply