Koodo Community

Community

Solved

Phone won't connect to any WiFi


I have a Moto X Play, I have never had this issue until a few days ago. I can see the list of available WiFi networks, I can select them but it says "Connecting", and then "Saved", and it won't actually connect. I tried it at home and at several other locations and it does the same thing everywhere, so I know the issue is with my phone and not my router... I tried forgetting and reconnecting to networks, rebooting my phone several times and restored to factory settings (for both data and networks). Still nothing. I've tried reading online but nothing seems to work. I am getting quite frustrated... I need WiFi access when I travel daily so I really hope there's a solution to this... 😞

6 replies

Userlevel 7
Badge +4
You've gone through pretty much everything that I can think of. Did you ensure that power saving mode is off? Or wipe cache partition ? How long have you had the phone for ? If if has been less than one year, then I would suggest using the warranty at this point.
Power saving mode is off. How do I wipe cache partition? It's been less than a year yes. How does the warranty work?
Userlevel 7
Badge +4
https://motorola-global-en-aus.custhelp.com/app/answers/prod_answer_detail/a_id/106533/p/30,6720,9392 A factory reset should also cover it (I presume that you meant that by talking about restoring to factory setting for data / networks) but may as well give it a go. As for the warranty : http://help.koodomobile.com/getting-started-with-koodo/before-you-purchase/what-is-your-warranty-and-repair-policy
Oh... It was a Certified Pre-Owned. I bought it in April... of course, I'm just about 3 weeks too late for the warranty... figures... 😞
Oh wait I misread... 6 months is for iPhones. So my phone could still be covered by the warranty if it's been less than a year?
Badge +4
Correct. Koodo Certified Pre-Owned Phones purchased after April 5, 2013 come with a 6-month limited warranty for iPhone and a 1-year limited warranty for all other phones.

Band-aid fix: Turn airplane mode on > Turn WiFi on > Turn airplane mode off. See if that works.

Edit: a couple of apps have been known to cause issues with the Moto X Play's ability to connect to Wi-Fi, (e.g. Gas Buddy and Touchtunes). Another option, try putting the phone in Safe Mode, if you're able to login to your home Wi-Fi, then an app is likely causing the conflict.

To get into Safe Mode: https://www.youtube.com/watch?v=qjlYJ...

Reply