Koodo Community
Question

Phone versions

  • 1 November 2020
  • 1 reply
  • 26 views

I currently have a Galaxy S5, have a couple devices that I cant run off it. the devices list S7 as a minimum & S9+ as the highest. Q: will higher version phones operate my devices?  


1 reply

Userlevel 7
Badge +4

The fact there’s a + sign after would tell me that there’s a high chance everything else released after will work with an S10, or S20.

Reply