Koodo Community

Community

Solved

Phone refuses to send texts for several hours


I have been having trouble with failed texts over the last month. everything else on the phone works, I can even receive texts. it just refuses to send my texts for several hours or even a couple of days at a time. This has been happening about once or twice a week. I have unlimited texts on my plan. My phone is a Samsung Ace. I bought it in January.

4 replies

Userlevel 7
Badge +4
Known issue with the galaxy ace. Go to settings, wireless and networks, mobile networks and turn off 'use packet data'. This will turn off your 3G data connection, but texts will send fine.
Userlevel 5
Timo Tuokkola wrote:

Known issue with the galaxy ace. Go to settings, wireless and networks, mobile networks and turn...

If you want to send picture messages however, you will have to turn on packet data, send the message then turn off packet data so you can receive and send normal texts.
Badge +4
I really think they should get rid of the Galaxy Ace once and for all as Samsung has made no effort to correct the issue described above. I realize newer models will inevitably supersede the aging Galaxy Ace and the device will eventually get pushed off the market, however the device continues to be sold today to unsuspecting customers. The Ace is flawed from the get-go, it's been a well-known fact for well over a year now and should be removed from store shelves as soon as possible. Customers should be warned in advance not to purchase this device and Koodo reps should try to persuade customers to choose something other than the Galaxy Ace.
Do you close the app before the text is sent? I had the same issue with my S3 and I had a friend with a One X with the same problem. You have to wait for the text to send completely before you exit the messenger app.

Reply