Koodo Community
Solved

OnePlus 8 Connectivity Issue


Userlevel 2

Does anyone here have a OnePlus 8? Have you had any issues with it staying connected to mobile data after turning off WiFi?

 

I have tried numerous things to try to combat this issue;

- Restarting phone several times;

- Removing SIM card and putting back into the phone;

- Replaced SIM with new one;

- Updated to the Android 11 beta to enable dual sim functionality, works with Bell sim card (no data issues) and switching back and forth.

- Cleared cache partition and even factory reset the phone. 

 

Koodo for some reason still pops up with an exclamation mark when trying to connect to LTE after turning off WiFi.

The only thing that seems to be a temporary fix is to switch the preferred network type back and forth from 3G to 4G/5G.

Any suggestions on what else to do to help fix this issue?

This is the only Android phone I've ever had these kind of problems with, it is the North American variant of the phone and it appears to be supported by Telus/Koodo the best, but real world usage would state otherwise at least in my experience. 🤷🏻

icon

Best answer by Glaurent 24 October 2020, 02:15

Hello! 

 

I’ve had the same issue with OnePlus 6T. After phoning Koodo a while back, I was told it was a device issue. After several phone calls and tests with OnePlus, they say it’s a network issue. I have tried everything, but have just entered the APN setup @Dinh suggested. So far so good. Not sure how things are going now @DanG90 but I sure hope you have no further complaints! This has been a pain!

View original

21 replies

Userlevel 7

Do you have a low signal level in your area? How many (4G LTE) bars do you have?

Userlevel 7

Please read the following (Verizon) link https://www.verizon.com/support/knowledge-base-230915/

OnePlus 8 5G UW - Auto Switch Between Wi-Fi & Mobile Data Networks

Note Notes:

  • When enabled, this advanced setting allows the device to switch from a weak or unstable Wi-Fi network to the Verizon cellular network to preserve consistent data throughput.
  • This function isn't enabled by default; the device prompts the user to enable the feature the first time they experience poor Wi-Fi connectivity Weak Wi-Fi icon.

If you have a strong mobile signal in your area, by disabling the ‘Auto Switch’ feature, you will prevent this wifi-LTE hoping from occurring.

Userlevel 2

@nim4165 I normally have 3-5 bars of network strength in most places I go. 

 

As far as that Wi-Fi suggestion, the setting is not enabled on my phone. The issue is not that it's hopping from wifi to mobile data, it seems to happen when I disconnect from my home wifi, the signal indicator pops up with an exclamation mark and my data stops working. 

Userlevel 7

I responded, even though I do not own a One Plus 8, because I though I knew the cause. I am therefore officially out of my depth here. Hope that a  ‘real’ One Plus 8 user can help you out. Good luck!

Userlevel 2

@nim4165 I appreciate you taking the time to try to help 😊 hopefully someone has an answer

Userlevel 7
Badge +4

I assumed you could make/receive calls and text normally.

The issue could be from the APN settings in your Oneplus. I would suggest you recheck it . Here is their official settings https://www.koodomobile.com/en/help/setting-data-your-non-koodo-phone

This link also  offer some troubleshooting ideas https://www.koodomobile.com/en/help/i-cant-connect-internet

I believe the preferred network mode should be set to “LTE/WCDMA/GSM Auto”.

Userlevel 2

@Dinh believe it or not, I've tried that too 😔 I've reset the APN settings several times, added the APN manually and even that doesn't fix it.

I always try to have it set to 2G/3G/4G (Automatic) (Pictured below). The issue I'm having though is when I've been connected to my home wifi for a period of time, and then I switch to mobile data, I get an exclamation mark within the signal indicator and my data stops working altogether. The only temporary fix is to switch to 3G then back to 4G, but it continues to happen. 

 

Userlevel 7

Just a shot in the dark! Is your data saver enabled? Data saver may disable background processes which may affect continuity/up-to-date values of the mobile data configuration parameters.

Userlevel 2

@nim4165 Sadly it's already turned off 🤷🏻

Userlevel 7
Badge +4

I didn't see the APN settings in the snapshot, could you take a snapshot of it and post again?. After setting apn, I would suggest you to restart the phone and see if there was an issue with firmware somewhere. 

Also I assumed you set data access to your Koodo SIM?  (sim1)

Userlevel 2

 

Userlevel 2

@nim4165 @Dinh these are the settings currently put in on the APN which the phone has reset to after resetting my network settings, and data access has been turned on for that sim card, but as you can see the exclamation mark in the signal indicator above 👆

Userlevel 2

@Dinh Sadly enough the issue I'm experiencing has carried over from Android 10, which is also disappointing. 

Userlevel 7
Badge +4

From your screenshots, the APN was correct. The data should work. I was puzzled by it. 

So I took out my SIM and tried it in a Huawei p20 and checked what the automatic APN was. It turned out the P20 is using a different settings (received from Koodo). I am not sure if this will work in your phone but you could try. The settings are below. Data, MMS worked on the p20 without any problem. If this doesn't work, you might want to check in with Koodo tech or do a factory settings and see if that can help. 

 

Userlevel 7

FYI

My Proxy (below APN),  my Port (below Proxy and my APN Type are all blank. The rest are the same.

As I already mentioned - My Data Saver is Off

There may be an explanation to the differences in line 1 above due to reasons that I am not aware of.

Userlevel 2

I've entered the info into a new APN setting, and so far my data is staying connected. I'll try it overnight to see what happens. I'll reach out if anything changes. 

@Dinh and @nim4165 thank you both for your help 😊

Userlevel 7
Badge +4

Great to hear that APN is working for your phone. I guess there was some incompatibility somewhere that created your phone problem. 

Userlevel 2

@Dinh Just checking in after a few days of using the phone normally with that new APN set up, and I'm happy to say there have been no issues with keeping data connected, thank you again for your help 😊

Hello! 

 

I’ve had the same issue with OnePlus 6T. After phoning Koodo a while back, I was told it was a device issue. After several phone calls and tests with OnePlus, they say it’s a network issue. I have tried everything, but have just entered the APN setup @Dinh suggested. So far so good. Not sure how things are going now @DanG90 but I sure hope you have no further complaints! This has been a pain!

Userlevel 2

@Glaurent It's definitely not a device issue, at the end of the day. It think it's something with the way the Koodo sims have their apns installed on them. For some reason the Huawei phones have a different APN set than what is installed into the OnePlus phones after putting in a Koodo sim card. I've put in the APN settings @Dinh suggested and I no longer have the issues I had before 🙂

 

***Side note: be mindful when you get a software update to your phone, it can end up resetting your APN settings and you will need to enter the settings again for that APN listed above.

I have a Oneplus 7pro with koodo as the carrier. I can say with certainty that it is a combination of device and carrier that are the source of the problem.

First, Oneplus 7 and most likely 8 do not have the all the necessary APNs for Koodo and Telus built into the system. While I have not seen a difference between the two APNs listed above (both work for me with no issues), the 1+ apn lists do not have the IMS,.SOS or Koodo Services APNs (same goes for Telus).

My device always defaults to Telus, even though I have never had a telus account or sim card. Which leads me to believe that the Koodo SIM does not download the correct APN settings, instead it looks for the SIM code that corresponds to the APN list on the device and then loads those APNs. Koodo and Telus on the 1+ APN xml file both have 302 and 202, but they lack the carrier id. So the device can not distinguish between telus and koodo so it loads all the apns with 302 and 202. It is only when I select sp.koodo.com, that my LTE data connects, otherwise I only have voice.

I have rooted my 7pro and in the process have changed the APN.xml file to include the carrier id, IMS,SOS and Koodo services apns. Now my device defaults to the Koodo APN setting and not Telus.

The sad part, and this is where the carrier is at fault, is that loading a Bell/Virgin Sim card on the device, everything loads properly and VOLTE works with minimal modifications to the device (aka no root needed). Telus/Koodo have decided to lock down VOLTE to a specific IMEI range, which does not include 1+ devices. The whole song and dance of not compatible with our network, is a bag of BS. If Bell/Virgin can do it by loading the configuration on their sim cards then why can’t Telus/Koodo.

The reality is that when Canada follows the US and dumps 3G, making 4G and Volte the main stream for voicecalls, people like you and I who do not want to spend $800+ on a device they do not like from the carrier and choose to spend their money on an android device they want, will also have to switch to Bell/Virgin and to some degree and device modification Freedom to be able to make a phone call. Unless Telus/Koodo change their ways.

Reply