Koodo Community

old phone wont use data

I just signed up with Koodo today and I am having a problem. I am using my old phone I got from Bell. (an Alcatel Onetouch Idol 😵 While I am able to make calls, I cant seem to use data on this phone.  To fix this issue, I have tried the following things.

Turned on Data Connection

Turned On Mobile data

Set Network Mode to GSM/WCDDMA auto

Manually Selected Koodo 3G in my Alavailble Networks

Turned Data Roaming on(also tried with it off)

And I am still having problems getting any app to use mobile data. Anyone have any Ideas on why I can't use mobile data, or is my phone just too old?

4 replies

Userlevel 7
Badge +4
Try to check your APN setting
Badge +4
Data roaming can be turned off. Everything else looks okay. WCDMA only if you see that setting works too. Koodo does not operate a 2G GSM network, so the phone ends up looking for a network that doesn't exist. Follow Mayumi's suggestion regarding APN settings. Keep us posted.
Thank you both. My mobile data is up and running now.
Try borrowing a koodo phone. Insert your sim and see if you can use it the way you want. This will register your sim into the koodo network. Review the settings in that phone than works and replicate it in your own phone.