Koodo Community

Community

Solved

Not registered to a network


I just bought a samsung galaxy core phone and established an account with koodo. I was able to briefly use the phone and not it says I'm not registered to a network. Is this something I can fix or do I have to return this phone?

2 replies

Userlevel 7
First thing to try is powering down your device and removing the sim card and, if possible, the battery Wait a minute and then reinstall the sim and battery. Restart your device. Didn't work? Check and be sure you're not in Airplane or Flight Mode. Still not working? Navigate to your settings and mobile network settings. Be sure that: Network Selection is set to Automatic USE 2G Only or USE GSM ONLY isn't selected Network type typically should be "GSM\WCDMA PREFERRED" Still not working? Change NETWORK SELECTION to Manual The device will perform a scan which could take up to 2 minutes. You'll be presented with a list of available networks. Choose Koodo or Telus from this list.Note: Doing this disables international roaming. Should you ever want to roam in the future you'll need to change this setting back to automatic If your device still isn't working, check and be sure your bill is paid up and then give Tech support a call. It's free. You can reach Customer Service at 1-866-99-KOODO (1-866-995-6636) or 647-788-4337. Hours of Operation Monday - Friday: 10am - 9pm Saturday: 9am - 7pm Sunday: 9am - 7pm
Userlevel 7
Badge +4
Chad Burr wrote:

First thing to try is powering down your device and removing the sim card and, if possible, the b...

That decision tree should be posted as a [b]blog reference: [i]No Service Could also add that if user is roaming, pay per use and international long distance should be enabled. Also, get rid of that silly 99-KOODO phone number. Already sent several corrections to crabby sheepish folks dialing KØØD (zeros-for-ohs) by mistake. Keep up the good work.

Reply