Koodo Community

Community

Solved

not registered on network


error message "not registered on network". Just started late today.This has happened before; shutdown restart I think solved the problem. This time I even took out the battery...no luck. It is an LG Optimus

12 replies

Userlevel 7
Badge +4
Aye, sounds like there might be a problem with either the phone or the SIM card itself, Steve 😞 Do you have access to another phone so you could troubleshoot if it is indeed the SIM card? Is the phone still under warrantee? Oh and one last question, have you tried to select the Koodo network manually?
Userlevel 7
Sophia wrote:

Aye, sounds like there might be a problem with either the phone or the SIM card itself, Steve 😞 ...

Apparently you nailed it!
Hi, The phone is not under warranty. The neighbour called and he received the message " the person is not taking calls at this time". I tried setting the Koodo network manually and I get a message " unable to connect to this network at this time"
Userlevel 7
Badge +4
Steve Skerlak wrote:

Hi, The phone is not under warranty. The neighbour called and he received the message " the pers...

Do you have voicemail? It is weird that it's saying that unless you dont have voicemail
Userlevel 7
So are you sure your bill is paid up? Just asking 😉 Check in selfserve and see if you owe anything.
Userlevel 7
Chad Burr wrote:

So are you sure your bill is paid up? Just asking 😉 Check in selfserve and see if you owe a...

Time to call Koodo, there may be an issue with the service in your area, your sim, or your phone Is this a rooted Optimus?
Chad Burr wrote:

So are you sure your bill is paid up? Just asking 😉 Check in selfserve and see if you owe a...

No it is not a rooted Optimus
bills are all paid up.. nothing is owing
Userlevel 5
I agree with the above that it could be a faulty sim or something, but do you have it set to 2G only mode? The phone needs to have access to 3G, HSPA, or WCDMA depending on what the settings are called on your phone. It should be somewhere under Wireless and Networks in the settings.
Userlevel 7
Jorden wrote:

I agree with the above that it could be a faulty sim or something, but do you have it set to 2G o...

I thought that too when he does a scan telus / koodo shows up. If the phone was in 2g mode idt it would have.
Userlevel 5
Jorden wrote:

I agree with the above that it could be a faulty sim or something, but do you have it set to 2G o...

Good catch!
Root cause: faulty sim card. Koodo replaced it this evening after work. All is well. I would like to thank everyone for their timely contributions, to the problem discussion.

Reply