Koodo Community

Community

not receiving texts


For about 2 months now I have not been receiving all of the texts that I know people are sending me. I'll get screen shots over Facebook of texts that my friends have sent but I won't receive them in my messages. 

My phone is an lg g5, my plan is $40 500MB 500min Plan SFD and I live in Niagara Falls

10 replies

Userlevel 7
Badge +4
It could be due to some wrong configuration in network settings? have you tried to reset network settings?
Dinh wrote:

It could be due to some wrong configuration in network settings? have you tried to reset network ...

How do I do that?
Userlevel 7
Badge +4
Dinh wrote:

It could be due to some wrong configuration in network settings? have you tried to reset network ...

I found this on Virgin website: http://www.virginmobile.ca/en/support/step-by-step-phone-guides.html?p=lg_g5&a=how_to_reset_the_...

After resetting, you will have to enter wifi password again, as the network reset will clear them and set carrier network settings to default.

Userlevel 7
Badge +4
Did you have an iPhone before?
Robert wrote:

Did you have an iPhone before?

I have never had an iPhone, no
Userlevel 6
Robert wrote:

Did you have an iPhone before?

Are you per chance connecting to US cell towers on roaming (you said you're in Niagara Falls)? Not that it should prevent receiving SMS.
You receive some texts, but not all? The texts you are not receiving, are any sent from other Koodo/TELUS subscribers?
Are your friends able to receive all the texts that you send them?
Robert wrote:

Did you have an iPhone before?

Yes. I receive random texts and randomly don't receive others. I'm not sure what companies my friends are with. My friends don't all receive the texts I am sending. It varies between people. With some, I get none of their texts, and they get all of mine, or vice versa. Or, sometimes I only receive the 2nd message people send me. 
Userlevel 7
Badge +4
Robert wrote:

Did you have an iPhone before?

It's bloody tough. Sometimes backend gets overloaded in specific circumstances. The best you can do is make sure that everything is good on your end. Ideally you should switch to a messaging service such as whatsapp or BBM to ensure delivery.
Userlevel 7
Badge +4
Robert wrote:

Did you have an iPhone before?

I came across a bunch of articles dated around Oct 10, 2017 reporting a bunch of users not gettting about 20% of their SMS's. One article led me to a Reddit post which led me to a solution that wasn't given much attention but worked for me (and based on my experience with my phone, I suspect will work for everyone else as well!)

Go to Settings > 
Device Maintenance>
Press Battery (the bottom left button)
Scroll All the way down

You'll see two categories: 
"Unmonitored Apps" and "Always sleeping apps"

Select "Always sleeping apps". Here I saw my Android Messages app - my default SMS app. If you see your default SMS app here, then good news, this is most likely the cause of your issue.

Press and Hold the sms app, which pulls up a delete button in the top right corner. Make sure that the app is properly selected and hit Delete.

To make sure it doesn't happen again, you can go to "Unmonitored apps" and add your default sms app. 

I suspect that a sort of disconnect happened between the network delivering the SMS to your phone, and your phone's SMS app waking up and recognizing the data.

Hope this works for everyone else. 

From : https://community.koodomobile.com/koodo/topics/im-not-receiving-all-text-messages-sent-to-me-any-sol...

Robert wrote:

Did you have an iPhone before?

Thanks for this suggestion, but on my phone, when I go into my settings there is no 'device maintenance' folder, even when I search for it. Likewise, there is no 'unmonitored apps' or anything like that. I think the setting layout may be different for my phone

Reply