Koodo Community
Solved

No network/call service in Vietnam

  • 19 October 2020
  • 4 replies
  • 38 views

Hi,

I am just going back to Vietnam and my phone does not work anymore.  It shows no network connection, which means no roaming call/texting/data for me. I can only rely on the wi-fi Internet at the local area. Please help! 

My phone is kinda old too. It’s an S7, Samsung.  I would really appreciate your help!  

icon

Best answer by nim4165 19 October 2020, 14:17

You may get Easy Roam for #12/day and use your phone where you have network coverage. See local mobile providers that may work with your S7.

In your cell phone Network Settings, make sure that Roaming is enabled. Disable ‘Automatic selection of network’ and manually select one of the compatible local mobile providers from the list below. Good luck!

 

View original

4 replies

Userlevel 7

You may get Easy Roam for #12/day and use your phone where you have network coverage. See local mobile providers that may work with your S7.

In your cell phone Network Settings, make sure that Roaming is enabled. Disable ‘Automatic selection of network’ and manually select one of the compatible local mobile providers from the list below. Good luck!

 

You may get Easy Roam for #12/day and use your phone where you have network coverage. See local mobile providers that may work with your S7.

In your cell phone Network Settings, make sure that Roaming is enabled. Disable ‘Automatic selection of network’ and manually select one of the compatible local mobile providers from the list below. Good luck!

 

Thanks. I have a quick question as I go into the following:

Settings>Connections>Mobile Networks> and I see four options Roaming, Network mode, Access Point Names and Network Operators. I follow your advice and set Roaming to allow International voice/message/data roaming. 

However, I have no idea how to select one of the compatible local mobile providers. Is it part of the Network mode or Access Point Names? Sorry for my ignorance.

Thanks in advance!

Userlevel 7

It may be under ‘Advanced’ >Network  Once you disable ‘Automatically select network’ and tap below on ‘Network’> ‘Names and Network Operators’, after 1-3 minutes you should get a list of mobile networks. Select one by tapping.  Good luck!

Thanks. It takes quite a bit of work to get it done following your advice.

So basically I have set the network mode to GSM/UMTS instead of LTE/CDMA. Then I get into the network operators and choose the network provider that you provided. It works like a charm.

Thank you very much!

Reply