Koodo Community

Community

Solved

No Internet Access When Using My Galaxy Note II to Connect to Other Devices.


I am able to connect to other devices such as my laptop or my kids' iPods, but none of these devices will have internet access when running off of my Galaxy Note II Hotspot. I have tried numerous suggestions posted here on the forums, but none of them have worked and nobody seems to have a concrete answer to this problem. I spent an hour on Live-Chat with Samsung. They say the problem is at Koodo's end. If I am not able to resolve this issue in a timely fashion, I may have to switch carrier.

12 replies

Userlevel 7
Badge +4
What have you tried so far? Is it originally a Koodo note 2? I suggest trying someone else's non Koodo SIM to confirm that it is indeed a Koodo problem or not if APIs are all set properly. It's also still possible that it'd the phone given how old it is.
Tried various broadcast channels as suggested by other members, but that has not worked. Samsung is suggesting that one of the settings is incorrect "at Koodo's end". I am NOT an IT guy, but I have used hotspots for years on my Blackberry's without issue. These same devices that I have no internet access to when connected via my Samsung will yield internet access when connected to my partner's iPhone.
Userlevel 7
Badge +4
Well there's no special setting for it. You could try sending a private message to koodo's Facebook page to see if there is something on Koodo's site. I have no issues with hot-spot with any device I ever used on Koodo. So to isolate the problem I suggest borrowing someone's Sim to put in the device not from Koodo or putting the Koodo SIM in say your partner's iPhone to see if the problem follows. Then that should tell you where th problem lies.
So went to see the retailer where I bought the Koodo package. He spent an hour trying to get my phone to work. They tried my SIM card in another Samsung phone. Remote internet works. Called Koodo. They say all of the settings for my phone are correct. Koodo suspects that the problem may have something to do with the fact that my phone was originally a Rogers phone. And round and round we go!
Userlevel 7
Badge +4
Gary Belanger wrote:

So went to see the retailer where I bought the Koodo package. He spent an hour trying to get my p...

I guess it is time to borrow a Rogers SIM!

Userlevel 7
Badge +4
Gary Belanger wrote:

So went to see the retailer where I bought the Koodo package. He spent an hour trying to get my p...

In your APN settings, change the line for APN type from blank to [b]default,mms,suppl,duns typed exactly as you see it.
Userlevel 7
Badge +4
Gary Belanger wrote:

So went to see the retailer where I bought the Koodo package. He spent an hour trying to get my p...

If your Sim works in another phone without issue then you've basically isolated the issue. Either your phone won't work at all for it due to some glitch(es) or go that last extra mile and try the Rogers sim just in case that somehow changes things as a curiosity. At the end of the day it's either not working at all or not with non-rogers providers, which still sounds weird to me.
Userlevel 7
Badge +4
Gary Belanger wrote:

So went to see the retailer where I bought the Koodo package. He spent an hour trying to get my p...

If the OP is on pre-paid, he is largely wasting his time. My Note II tethered fine on monthly but lost that ability when I switched to prepaid. Koodo is not the only supplier to work that way.
Gary Belanger wrote:

So went to see the retailer where I bought the Koodo package. He spent an hour trying to get my p...

My APN Type field is not a text field, but a radio button field with three options; <Internet + MMS>, <Internet> or <MMS>. The current selection is <Internet + MMS>

Gary Belanger wrote:

So went to see the retailer where I bought the Koodo package. He spent an hour trying to get my p...

I am on a monthly plan.
Userlevel 7
Badge +4
Gary Belanger wrote:

So went to see the retailer where I bought the Koodo package. He spent an hour trying to get my p...

I guess the Rogers firmware is showing. My Note II (Koodo) menus allow changing text fields in that area.

There is definitely a relationship between SIM, APN and firmware. When I used a ConsumerCellular SIM in the US a few years ago, the Koodo APN disappeared from the menu choices entirely to be replaced by theirs, which needed some adjustment. Swapping the SIM back when I returned to Canada brought everything back to Koodo immediately.

Goran's suggestion to try with a Rogers SIM would answer that issue.

If that's the case, then you would have to look at flashing the firmware with Koodo's version, not a trivial or risk-free process. Consider buying a cheap unlocked handset that can take a micro sim like your Note II for providing a hotspot if it's that important to you.
Gary Belanger wrote:

So went to see the retailer where I bought the Koodo package. He spent an hour trying to get my p...

Thanks to everyone that tried to help. Well, after almost 6 hours of fighting with my phone, 3 Koodo technicians, including a level 2, and 2 visits to the dealer who sold me the plan, it was finally my local dealer, Randy Henschel from Barrhead Sound who finally resolved my Hotspot issue. The APN for the phone was correctly set for the Koodo network, but the APN for "Tethered Mobile Internet" had not been changed from the previous Rogers network. Changed the APN address, problem solved!

Reply