Koodo Community

nexus 4 won't update

  • 25 January 2014
  • 8 replies

my wifes nexus 4 doesn't seem to want to update. when i go to the check for update and hit the check now nothing happens. it always says that it is up to date. but doesn't change the last checked 11/16/2013.it's running 4.3 we don't have data but connected to a strong wifi signal at home, fully chargered battery. any one have suggestions?

8 replies

Userlevel 7
Try turning off the phone for a little bit and then trying again. I've heard of people checking too many times and not getting the update.
will try that. Ive powered off and back on a few times but not waited more than 1 min to power back on. will give it 10-15 minutes off this time.
Userlevel 7
Badge +4
Try while the phones on to hold the power down until the phone shuts off and keep holding it till the phone turns back on, so holding the entire time so it powers off and back on without letting go. Also quick question, Did you buy it second hand? If you did it May be that it's been rooted and unofficial software flashed which would make it so the official update would not show until it's flashed back to the stock firmware.
phone was purchased from koodo. off for 20 min then powered on still no diference.still says last checked 11/16/2013, so its as if it not actually checking for update. Will try the hold power suggestion when wife comes back home. thanks
still no luck
Does other applications work through the wifi?
You can try this http://www.cultofandroid.com/45466/manually-install-the-android-kitkat-update-on-nexus-4/
yes everything else seems to work fine through wifi. I'll check out the link provided. thanks