Koodo Community

Community

Solved

Nexus 4 - Rebooting when I ensable 3G or Wifi (disable airplane mode)


As of tonight, my Nexus 4 which has proven generally reliable since I bought it some time ago when I started with Koodo, was in a reboot loop after I tried to wake it up from sleeping. It kept rebooting a few seconds after I had unlocked the screen. 

I am running KitKat 4.4 as I'd heard of some sizable problems with 5.0 and figured KitKat was working wel for me (until this point). 

I was able to halt the reboot cycling (couldn't even turn the device off - it would cycle again) by turning Airplane mode on. Then it comes up and is stable. 

If I turn on either Wifi while in airplane mode) or turn airplane mode off and disable Wifi leaving only 3G active, the phone goes back into the reboot loop. 

I'm wondering if the Koodo SIM chip could somehow have given up the ghost or if some other network change might be involved? 

Currently, until I get all my data (pics, docs, etc) off the phone, I see to have to keep it in airplane mode. Once I've saved everything, it would be possible to try a factory reset I suppose. 

Thoughts? I don't want to try the 5.0 or 5.0.1 update while this rebooting loop is going on - it might mess up the update and brick my device. 

12 replies

Userlevel 7
Try removing the sim card and booting. Turn off airplane mode and see what happens.
Further refinement:

I can leave 3G up if mobile data is disabled. Turn on mobile data, the phone reboots cyclically. 
I can leave Wifi up as long as I have no credentials in any of the networks - it can scan for networks and remain stable. When it attempts to connect to a network, the phone reboots cyclically. 

This seems to me to point to one of two things (guesses of my own, may be entirely off base): That some IP-related data (used by both mobile data and wifi) is stored somewhere on a SIM card or in internal memory and that location has become corrupted OR the phone is using a chip or some other hardware to handle IP traffic and that component has failed. 

I will try a SIM-chip removal once I can figure out how this is accomplished on the Nexus 4. I will take it to the Kiosk for Koodo first and see what they suggest. If replacing the SIM chip changes the state of affairs, then that would be the issue. 

For now, I have voice and text messaging, but no data and no ability to update anything (with wifi down). I can connect the phone to a PC and begin extracting data that needs backed up. 

If anyone has any other ideas or suggestions, I am still glad to hear them. A factory reset is possible, just annoying with the amount of data I have to move around. 
I have the same exact problem. It started randomly the day before yesterday.
Alex K wrote:

I have the same exact problem. It started randomly the day before yesterday.

This problem is either from a Google patch (not full OS update as I haven't okayed that to go to 5.0.1 from 4.4) or perhaps from an app update. If it is a Google App issue with 4.4 (possible) or a third party app, then perhaps a safe boot which disables 3rd party code will work (I intend to attempt this to see if the problem goes away without any 3rd party apps). If the problem still persists, it is likely something in the OS or the google apps. 

On Google's own support forum for the Nexu devices, I've seen a handful of people who have reported the same thing with about the same start time and most of them, like me, seem to have had a stable phone for a long time. That much coincidence is likely possible (on the timing) but I'm suspicious. 
Userlevel 3
I was having issues with my Samsung Note2, not re-booting but just plain old buggy performance, so after trying everything I had googled and deemed worthy of a try, I finally resorted to a factory reset. It is much better and the actual restoring of apps etc. was relatively painless due to having had contacts and app data backed up to gmail (Google) and a couple of other Cloud based applications. In the long run it was worth it but only after I was certain every important item was backed up to my PC as well as the Cloud.
I have had to factory wipe a family member's IPhone after a mistake was made in the unlock process and due to it being backed up properly it too was relatively painless although some items were missing but easily replaced.
***Back up your device regularly and a factory reset is not so daunting.It may even save a few brain cells****

grampad wrote:

I was having issues with my Samsung Note2, not re-booting but just plain old buggy performance, s...

I'd agree but not all apps back up their data (and some should not, such as those that contain encrypted passwords - I see no reason for them to ever send data into the wild). I have likely about 100 apps installed so reinstalling those will take time and eat data bandwidth. 

If all you ever use is a few google apps, then factory reset isn't such a big thing.  If you have a lot of apps installed and working (or that wee). 

For me, the data recovery and app recovery after a factory reset will likely take the better part of a day even with various built in data back active. 

And, if you've lost wifi and mobile data like I have, there is no way to sync up so any recent work that wasn't sync'd will be lost as I understand it. 

Techno Bill posted a solution that seems to work (for at least one person) for this problem based off what he saw on an XDA forum. He also posts some data that may suggest a null pointer in some logging may be involved (or not, it could just be roughly coincident). 

Anyway, his repair seems to work for others and I'm going to try it. It does mean ejecting your SIM but I'm not quite sure why that part is required. It does require getting your phone to stay up long enough to let you clear data from several google apps via settings. 

http://productforums.google.com/d/msg/nexus/hxKVc2dy2is/qovqOU-mBQAJ
The short answer with the least unnecessary screwing about  (it was Greg Fortune whose answer I meant to refer to, not Techno Bill, but it is in the same thread): 

[b]1. While in boot cycle, quickly unlock phone, pull down top menu bar, tap on icon in top right corner opening up the toggles for things like wifi/bluetooth/airplane mode/etc. Select Airplane mode.
 
[b]This should stabilize your device and stop boot cycling.
 
[b]2. Go to Settings -> Apps -> All and find (under G since they are alphabetic) Google Services Framework. 

[b]Tap on it to open. Select Clear Data (and Clear Cache if it isn't greyed out by clearing the data). 
[b]This should have fixed the corrupted info by wiping it. 

[b]3. Go back to your settings and turn airplane mode off. 

[b]If your phone doesn't immediately start rebooting, you've fixed the corruption causing the boot loop. 


It looks like a coding issue (and obviously poor quality assurance) in Google Services Framework or something that uses that framework (related to logging when network connections are made likely) is the likely cause. Google will eventually fix this and ship an update one hopes. 

It is possible you will see it again and this solution should work then if it recurs as well. Fixing the code is the permanent answer, but it might only happen in some rare circumstance so it may not be seen again or very often. 

Userlevel 1
[b]if your technical you might have to pull the image off your phone and put it back on using  fast-boot as it sounds like one of the critical files in your phone has corrupted. if you have your phone rooted and have recovery flashed in to the phone  go in to recovery and clear cache. [b] non technical your best bet is to reset the device and see if that kicks the problem,  but make sure to pull off all important files though usb since there's no sd slot as well in the future look in to back up services like box or Dropbox incase something similar happens it can save you time and you have all files backed up to the cloud.
Todd wrote:

[b]if your technical you might have to pull the image off your phone and put it back on using...

The post just above yours contained the answer. This was identified on the google nexus forums and other places like XDA. 

I took the three steps outlined  in my last post in this thread (put in airplane mode, go into settings->apps->all and find Google Framework Services, click on it and then clear the data it contains, then go back and turn airplane mode off. 

The issue is corruption in some data in Google Framework Services possibly related to some poor code that was pushed recently. 

The phone now no longer reboots. 
Userlevel 1
Todd wrote:

[b]if your technical you might have to pull the image off your phone and put it back on using...

glad to see it got fixed its never pleasant to have a phone that goes in to a boot loop 
Todd wrote:

[b]if your technical you might have to pull the image off your phone and put it back on using...

Your solution worked for me as well. I followed all your steps and now my phone is back to normal. Thanks for your post Tom B its really appreciated 🙂

Reply