Koodo Community

Community

Solved

Nexus 4 not able to connect to Koodo


I went to koodo with my new Google Nexus 4, and they couldn't connect it to the koodo network. They didn't know what to do. Does the Nexus 4 work with Koodo?

11 replies

Userlevel 7
Badge +4
Yes the Nexus 4 should work fine with Koodo. Did you change your APN settings to Koodos? Is anything working at all? Calls? Internet?
Userlevel 6
Yeah it definitely works, however, did you perhaps try changing something accidentally in the *#*#4636#*#* menu that you shouldn't have? That's where the LTE setting is enabled for the Nexus 4 so if you were tinkering in there and switched off the wrong thing that might be the problem.
Userlevel 1
What John said but if you were in that menu, try to change it to WCDMA only. That's the setting I have on my phone and it's not a Koodo phone to begin with.
Userlevel 7
Badge +4
samsvoc wrote:

What John said but if you were in that menu, try to change it to WCDMA only. That's the setting I...

I have my International Galaxy Note 2 on GSM & WCDMA AUTO, & it works fine so that shouldn't make a difference. Though if it's on GSM ONLY there might be an issue I guess.
Well, basically I handed my phone to the koodo representative, and after they tinkered awhile, they were unable to connect. I didn't try to change any settings myself. I guess I have to take things into my own hands.
Userlevel 7
Gabriel P wrote:

Well, basically I handed my phone to the koodo representative, and after they tinkered awhile, th...

Koodo can't provide support for unlocked devices as they aren't trained with dealing with every type of phone. You're sure your mobile network is on and everything? I would try a factory reset on the phone and seeing if that does the trick. I feel like a setting in you phone is preventing you from connecting to the network. Also, have you at all replaced the sim card or did the rep suggest it? It COULD be the sim card. I would swap it out for a new one. SIM cards also come with a warranty so you shouldn't have to pay for another one
Gabriel P wrote:

Well, basically I handed my phone to the koodo representative, and after they tinkered awhile, th...

This is what hapened exactly: I was at the koodo booth. The rep couldn't connect to the koodo network. The rep suggested I go to Telus and have them register my phone with their network. So I went to the Telus booth. They put in a Telus sim card, and tried to connect to Telus. Again, no connection. They had no idea what to do. As I walked back to the Koodo booth I asked the advice of another cellphone booth. The guy there had a phone with Rogers. He used his sim card on my phone - It successfully connected to Rogers. Then I went back to Koodo, and the reps ran out of ideas, and only suggested getting a refund for the sim card I had bought from them, so I did.
Userlevel 1
Gabriel P wrote:

Well, basically I handed my phone to the koodo representative, and after they tinkered awhile, th...

Make sure your phone is set to receive hspa and not gsm.
Userlevel 7
Badge +4
Gabriel P wrote:

Well, basically I handed my phone to the koodo representative, and after they tinkered awhile, th...

Indeed. I'm pretty sure rogers is the only provider in Canada with a gsm (2g) network,so if your phone will connect to rogers and nobody else it's a pretty sure sign that it's in gsm only.
Userlevel 7
Badge +4
I was able to connect to Koodo automatically just by placing the SIM card into the N4. The network settings are read automatically from the SIM. If Rogers worked and Koodo/Telus didn't, I'm willing to bet that for some reason your phone has 3G disabled. The diagnostic menu should allow you to change this. Open your dialer and type in: *#*#4636#*#* Choose "phone information" and select "WCDMA only" if you don't travel abroad or "WCDMA preferred" if you do.
Userlevel 7
Badge +4
Ivan wrote:

I was able to connect to Koodo automatically just by placing the SIM card into the N4. The networ...

Why do you need to punch in that code? It can be switched in the settings menu.

Reply