Koodo Community

Community

Solved

"New voicemail" notifications won't go away


Does anybody else have trouble with the "New voicemail" notifications constantly showing on their phone? After I listen to my voicemail messages and delete them, it still shows up as a "New voicemail" notification on the home screen and in the notifications on the phone. I have no more voicemail messages (not even saved ones) but the notification won't go away. I am on a Nexus 5 with Lollipop 5.1. Thanks.

15 replies

Userlevel 7
Try calling your number from another device and leave a message. Then go in and delete the message. See if that works
Chad Burr wrote:

Try calling your number from another device and leave a message. Then go in and delete the messa...

The key is waiting until the notification icon clears after you delete the voice mail (before you hang up).  If you hangup before the icon disappears, it will remain there because the system didn't have enough time to "tell" it to disappear.
Userlevel 7
Chad Burr wrote:

Try calling your number from another device and leave a message. Then go in and delete the messa...

It doesnt matter if you hang up first. I have a lot of experience with this.

Look at the dates of threads you're replying to please, Steve. This thread is 4 months old. Commenting on old threads brings them to the front page and we dont want it cluttered with old posts
Chad Burr wrote:

Try calling your number from another device and leave a message. Then go in and delete the messa...

I tried the solutions suggested here and they didn't work for me, anyway. There don't seem to be any more current answers. I found a solution on another forum and was happy to share in case it helped someone. Hope it hells someone else.
Chad Burr wrote:

Try calling your number from another device and leave a message. Then go in and delete the messa...

I understand that this is a Koodo site, but I have a Tablet plan with Virgin mobile Canada (Data only, so no VM) and everything I tried so far is only temporary, the VM icon comes back if my phone is restarted or loose data signal. 
I called Virgin and they say it is my phone which is suppose to be a tablet.
So far the best I can do is Clear Data or Stop the "Telephony Service" on my Asus Zenfone 2. There are a few apps in the Google Play store to Clear VM icon, but they do not work with Android 5.0.

Any other ideas would be welcome, thanks in advance.

Userlevel 7
Chad Burr wrote:

Try calling your number from another device and leave a message. Then go in and delete the messa...

Try settings... Call... Clear Voicemail notification
Chad Burr wrote:

Try calling your number from another device and leave a message. Then go in and delete the messa...

Under Call settings, I do see Voicemail, but no option to clear notificaion ! I'll search and see if Asus put it somewhere else.
Userlevel 7
Badge +4
Do you have data enabled. I believe you need data in order for the server to communicate to your phone that you don't have anymore VM. It's only a hypothesis
Userlevel 7
Robert wrote:

Do you have data enabled. I believe you need data in order for the server to communicate to your ...

That's done by hidden sms messages the carrier sends to your phone.
Having data enabled doesn't have an effect. It worked fine at first. This behaviour started a couple of months after I got the phone. I never needed data enabled previously, so I don't think I should need it now.
Userlevel 7
Chad's suggestion should fix the issue. This is a common problem.
Ahmad wrote:

Chad's suggestion should fix the issue. This is a common problem.

Tried it. Didn't work.
Badge +4
Try going to: Settings > Apps > All - scroll down to Phone and tap on Clear cache and Clear data.
Ok, press on the icon, move to the sides, options come up, listing the different categories of phone services, select voice mail and set to low importance, and that gets rid of the icon from display.

Userlevel 7
Badge +4
Deepa Menon wrote:

Ok, press on the icon, move to the sides, options come up, listing the different categories of ph...

Just so you know, this thread is from 3 years ago.

Reply