Koodo Community

Community

Solved

New phone, No Data connectivity.


I just got a new phone (galaxy SIIX), but did not change my plan. Now the Data does not work. Will not turn on. Even if I uncheck and recheck the 'enable data' box in settings. I also installed a data toggle widget, still no data. What should I do?

5 replies

Userlevel 5
Since you didn't change your plan, did you have data blocked on your account with the previous phone? If so make sure to remove the data block.
Userlevel 7
1. Go to Settings - More... - Mobile Networks - access point names. Ensure that it says Koodo SP and has the correct codes in there. Look at switch2koodo.com for more info on those #s. 2. You didn't change your plan? Does it have data and no data block on the account?
I did not have data blocked, and the new phone was purchased directly from Koodo yesterday. I did check the access point names (Settings - More... - Mobile Networks - access point names) and for mobile internet it lists "sp.mb.com", and tethered internet: "isp.mb.com". Oddly the box for 'mobile internet' was unchecked, and now that I've tried checking it (still no internet) it will not let me uncheck it.
and yes, it does have data on the plan. I have not changed the plan. And I have not exceeded my data in this pay period either.
Wow! Thank you Jonathan. Yup I did just buy a phone direct from koodo that had a faulty access point name set up. I followed your instructions and went to switch2koodo.com did a search for apn codes, and then arduously entered all the codes, and hit save. Worked right away. Hilarious. Someone at the factory fell asleep I guess.

Reply