Koodo Community

Community

Solved

New GS3 wont mirror screen after 4.4.2 update.


i just got a GS3 yesturday and was very happy to use the screen mirror but right after i updated to 4.4.2 iTunes stop working. devices see each other but connection fail. any solutions?

5 replies

Userlevel 5
Hey Christian, Have you tried to check if there's an app that allows you to establish a connection? You should be able to find some on Google Play Store. Keep us posted! ******************************************** If you see a good answer, give it a star.
Yes, i checked the Google Play Store, tried a couple Apps, could connect and play files with DLNA but din't find anything to use Miracast (screen mirroring). The screen mirroring wich i confirm was working at the Koodo Store is why i picked a new phone.and as i said earlier it worked great before the update. I'm looking for a solution for the screen mirroring to work again. If someone know an App that can mirror screen i would try it but i'd preffer using the android built in option as last night!
Original post should read '' right after i updated to 4.4.2 IT stop working''
Userlevel 5
Hey Christian, Thanks for your reply, if you tried screen mirroring with other apps and it worked, chances are it's a compatibility issue after the update since this only seems to happen with iTunes (did you update iTunes by any chance?). You can try a factory reset to see if this helps you reconnect your phone to iTunes or use one of the following apps: http://koo.do/1ADWZYf Hope this helps! ******************************************** If you see a good answer, give it a star.
@Tayeb,,, i guess you din't read all my posts,,, i din't have trouble connecting with Itunes,,, the auto correct wright itunes instead of IT. And i could NOT connect with an APP.... i connected DLNA with an APP witch is not MIRACAST used by screen mirroring on the Galaxy S3. Tonight i tried to connect my projector with someone else S3 wich is also updated with Android 4.4.2 and the same problem occured. I tried factory reset and HARD reset with no success. Keep in mind that the connection between my new unupdated GS3 worked fine before the 4.4.2 update!!! I'm in contact with Celluon; the manufacturer of the projector and will update if resolution happen. If we can't resolve, i'll return the phone and cancel the service. Thank you for your interrest tho.

Reply