Koodo Community

Community

Solved

Network unavailable


Samsung Galaxy SIII Kicked off the Koodo Network and now when I go into Network Settings it doesn't even find the Koodo Network...I tried calling in and they refreshed my network on their end but it's still doing it..they can't even call me back... Any ideas ?

15 replies

Userlevel 7
Badge +4
You make sure your 3G is on? Try pulling the battery and sim for a few mins and try again. Try another Koodo sim to ensure it is a not a SIM card issue. Or try your sim in another phone. make sure airplane mode is not on. Backup and perform a factory reset
Userlevel 7
Dennis wrote:

You make sure your 3G is on? Try pulling the battery and sim for a few mins and try again. ...

Before the factory reset goto: Settings Wireless and networking More Mobile networks Make sure "Use 2g only" or "use GSM only" isn't checked. Also make sure network selection is set to "Automatic" If its already set to automatic, change it to Manual. Your phone will perform scan and present you wil available networks. Choose Koodo or Telus.
Dennis wrote:

You make sure your 3G is on? Try pulling the battery and sim for a few mins and try again. ...

I can't choose any network... When I do a manual search it only shows Rogers...that's what has me stumped bcuz is not even finding Koodo at all...the Rep told me there was no issue in my area but I've nvr had a problem here b4...always have 3-4 bars 😑
Userlevel 7
Dennis wrote:

You make sure your 3G is on? Try pulling the battery and sim for a few mins and try again. ...

Check and make sure of that 2G\GSM. Thing Especially if you're only seeing Rogers
Userlevel 7
Dennis wrote:

You make sure your 3G is on? Try pulling the battery and sim for a few mins and try again. ...

Network selection should be Wcdma\gsm auto
Dennis wrote:

You make sure your 3G is on? Try pulling the battery and sim for a few mins and try again. ...

It is that selection
Userlevel 7
Badge +4
Dennis wrote:

You make sure your 3G is on? Try pulling the battery and sim for a few mins and try again. ...

I think it's time to Try another Koodo sim to ensure it is a not a SIM card issue. Or try your sim in another phone.
Userlevel 7
Dennis wrote:

You make sure your 3G is on? Try pulling the battery and sim for a few mins and try again. ...

And you did check the 2G thing right?
Dennis wrote:

You make sure your 3G is on? Try pulling the battery and sim for a few mins and try again. ...

I don't have a 2G option but after 2 network refreshes on Koodos end it seems to b working again for now lol... THANK YOU for all the helpful info tho 🙂
Is it a white one. When did you get it.
Userlevel 7
Badge +4
Adeel Salman wrote:

Is it a white one. When did you get it.

Also did you do any recent OS updates?
Adeel Salman wrote:

Is it a white one. When did you get it.

It's a blue one I got a few months ago at Koodo... I've tried powering off... Removed battery and SIM... Turned airplane mode on and off again...Last OS update was a month or more ago
Adeel Salman wrote:

Is it a white one. When did you get it.

Have you tried getting your sim replaced?
What exactly is your location?
After 2 network refreshes on Koodos end phone seems to b working again...thank you for the tips tho 🙂

Reply