Koodo Community

Community

Solved

" My Phone Number" shows as "Unknown".


I have a samsung android phone. When my Rogers Sim is installed and I got to the settings / about phone the " My Phone Number" shows the Rogers phone number. When my Koodo Sim card is install the " My Phone Number" shows as "Unknown". Any ideas why?

8 replies

Userlevel 7
Badge +4
Is the phone a Rogers bought phone? If so that could be the reason as its not a phone from Koodo, I know that my factory unlocked Galaxy Note 2 doesn't show my phone # under that area in the settings menu but using my Nexus 4, Galaxy S3, or Galaxy S4 bought from Koodo it does show my # in that area. Either way it doesn't affect the phone in any way so it's nothing to worry about. If you like having your # on your phone to remember it you can do what I do and just make an entry into your contacts as "ME" & input your phone # & other info there. Then if you need any of your own contact info Luke phone #, email addresses, ect it's all there in your contacts as ME
Userlevel 7
Badge +4
I have exactly the same thing! But, when I go into my contacts there's an already made category on top which is called me and it has my phone number there.
Userlevel 7
Badge +4
Robert wrote:

I have exactly the same thing! But, when I go into my contacts there's an already made category o...

Ya the newer Android phones I think those running Android 4.1and newer have a place in the contacts already set that says Me and there's a click able option to "set your profile". They stole my idea lol 😉
Robert wrote:

I have exactly the same thing! But, when I go into my contacts there's an already made category o...

I see the ME and have set it up. My original phone - which I still have is a Samsung Galaxy Nexus which was a Google phone that only came unlocked. My original service provider at that time was Telus and the My Phone Number showed the correct number. I then moved to Roger's and the My Phone Number worked. I got Koodo as a second account due to travel areas and better coverage but the Koodo in the Nexus never showed in My Phone Number. Needless to say switching SIM is a pain so I have just purchase a Samsung Galaxy Grand Duos (GT-I9082) - which is a dual sim unlocked phone. The Rogers SIM phone numbers display correctly and immediately but again the Koodo phone number still shows as Unknown.
Robert wrote:

I have exactly the same thing! But, when I go into my contacts there's an already made category o...

And thanks for your assistance and comment none the less guys. It's appreciated.
Userlevel 2
Hey Ross, this number will be updated on it's own by the system. It may take time before it changes. This isn't anything to worry about though.

________________________
If you see a good answer, give it a star.

I have the ME field in Contacts in my new Galaxy S4 Active, sync'd to my Google Contacts. The ME entry is currently empty - and it doesn't allow me to add any phone number fields! What's up with that?
Userlevel 7
Kate Bernhardt wrote:

I have the ME field in Contacts in my new Galaxy S4 Active, sync'd to my Google Contacts. The M...

Try editing it through http://contacts.google.com

Reply