Koodo Community
Solved

My BLU Android phone doesn't ring when I get a call? All other notifications make a sound?


I've tried adjusting all my Settings, but nothing seems to work.  It's only an issue when I receive an actual telephone call.
icon

Best answer by rikkster 11 November 2019, 02:17

 

looking at the above info, what is the priority mode?

 

Priority Mode is similar to Do Not Disturb Mode. When you press the volume up key, you may see the option for Priority mode. Tapping Priority may disable Priority Mode or take you to Priority settings to turn this feature off.

 

 

To check if Do Not Disturb is enabled, swipe down from the top of the screen so that all icons are visible in the window shade. Look for the Do Not Disturb icon. If this feature is disabled, as it should be, there will be a circular icon with a diagonal line going through it. 

View original

21 replies

Userlevel 7
Badge +4
Have you made sure priority mode is off? Which BLU do you have?
Have you made sure priority mode is off? Which BLU do you have?I have a Life 1x2 - Android 6.0.1
Have you made sure priority mode is off? Which BLU do you have?I think my priority setting is off. This is my first smartphone. The operator is not so smart.
Have you made sure priority mode is off? Which BLU do you have?Oop, my telephone ringer is working now!
Thanks for your help!

You say you don't use a carrier. You only use voip. I would check that it might be voip causing the problem and not the phone or another app.
No, I use the Telus network.
Userlevel 7
Badge +4
No, I use the Telus network.You can make & receive calls?  It just does not ring?

No, I use the Telus network.Yes, I can make calls.  And if I happen to be looking at my phone & see a message indicating that someone is phoning me I can answer it.
Userlevel 7
Badge +4
Do you have Bluetooth or do not disturb turned on? Is the ring volume down? Some phones have different volume settings so you can have the volume up for notfications and everything else but down for your ringer.
Yup, I have media, alarm & ring volumes all set at maximum.

No, Bluetooth & Do Not Disturb are turned off.
Userlevel 7
Badge +4
No, Bluetooth & Do Not Disturb are turned off.
What about priority mode? Do you have a ring tone set?
No, Bluetooth & Do Not Disturb are turned off.
Yes, I set a ring tone.
Just tested it by phoning from my land line & it's ringing!

Good news - my telephone ringer is working now!
Not sure what did the trick because I investigated all your suggestions & rejigged a number of things.  Thanks for all your respones - much appreciated!
Userlevel 7
Badge +4
Good news - my telephone ringer is working now!
Not sure what did the trick because I investigate...
YAY!  Thanks for updating the community with your success.

hi,

I have the same problem: BLU vivo 8 with android 7:

I can not get a ring tone when someone calls or text me. Whatsapp works, alarm works, timer works, calls and text doesn’t ring. My ring volume (under sound & vibration) is grayed out.

looking at the above info, what is the priority mode?

please help

i miss all my calls

thx in advance

Badge +4

 

looking at the above info, what is the priority mode?

 

Priority Mode is similar to Do Not Disturb Mode. When you press the volume up key, you may see the option for Priority mode. Tapping Priority may disable Priority Mode or take you to Priority settings to turn this feature off.

 

 

To check if Do Not Disturb is enabled, swipe down from the top of the screen so that all icons are visible in the window shade. Look for the Do Not Disturb icon. If this feature is disabled, as it should be, there will be a circular icon with a diagonal line going through it. 

hi rikkster; thanks for your reply; my system doesn’t have proprity mode...only ring vol, media vol, and alarm vol. Ring vol is grayed out, the others can be adjusted.

I have tried everything...somehow calls and text doesn’t ring.... everything else works.

thx

A

Badge +4

hi rikkster; thanks for your reply; my system doesn’t have proprity mode...only ring vol, media vol, and alarm vol. Ring vol is grayed out, the others can be adjusted.

I have tried everything...somehow calls and text doesn’t ring.... everything else works.

thx

A

An app may have taken control of the ringer volume slider. Putting the phone in Safe Mode loads only the apps that came stock with the phone. If the ringer volume slider works in Safe Mode, then a third party app is likely preventing the volume slider from appearing. It will be up to you to find which app is causing the problem. Start by uninstalling the most recent apps, first.

To enter into Safe Mode, power off the device. Press and hold the power button, when you see the BLU Vivo 8 logo, release the power button, then press and hold volume down button. Release the volume down button when you see Safe Mode on the bottom left corner. To exit Safe Mode, power off the phone and restart.

 

the problem is there with the safe mode. I might have to reset the phone if nothing works. Should i start deleting the apps for just reset the phone?

thx for you help: good info

Badge +4

the problem is there with the safe mode. I might have to reset the phone if nothing works. Should i start deleting the apps for just reset the phone?

thx for you help: good info

Since the problem is present in Safe Mode, deleting apps will have no effect. A factory reset may help. If the problem persists, then it’s probably a hardware related problem.

Reply