Koodo Community

Community

Solved

my alcatel onetouch keeps sayin no service i took battery out and sim card still nothing


9 replies

Badge +4
Hi David, How old is the SIM card you're trying to put in the phone? Could be a defective SIM.
rikkster wrote:

Hi David, How old is the SIM card you're trying to put in the phone? Could be a defective SIM.

it was brand new i have only been useing it a couple of months

Userlevel 7
Badge +4
rikkster wrote:

Hi David, How old is the SIM card you're trying to put in the phone? Could be a defective SIM.

Try turning Airplane mode on > off.
And/or taking sim card out and restart again.
Userlevel 7
Badge +4
rikkster wrote:

Hi David, How old is the SIM card you're trying to put in the phone? Could be a defective SIM.

I've had brand new SIM cards fail. Literally brand new, out of the package.

If Chad's suggestions below don't fix your problem, please head on to your nearest Koodo location to try a new SIM card.
rikkster wrote:

Hi David, How old is the SIM card you're trying to put in the phone? Could be a defective SIM.

My Alcatel keep saying no service
Userlevel 7
rikkster wrote:

Hi David, How old is the SIM card you're trying to put in the phone? Could be a defective SIM.

Did you try the suggestions I outlined below?
rikkster wrote:

Hi David, How old is the SIM card you're trying to put in the phone? Could be a defective SIM.

How to fix my alctel 1030a no service.
Userlevel 7
Badge +4
rikkster wrote:

Hi David, How old is the SIM card you're trying to put in the phone? Could be a defective SIM.

@ Be Bo

 Did you try Chad's suggestion? 
If it still not working, can you start your own post? We need more info to help you.
Prepaid or Postpaid?  Was it working before? what did you try fix it so far...etc.

Userlevel 7
Where did you get your Alcatel and what model is it exactly? First thing to try is powering down your device and removing the sim card and, if possible, the battery Wait a minute and then reinstall the sim and battery. Restart your device.

Didn't work?

Check and be sure you're not in Airplane or Flight Mode.

Still not working?

Navigate to your settings and mobile network settings.

Be sure that:
Network Selection is set to Automatic
USE 2G Only or USE GSM ONLY isn't selected

Network type typically should be "GSM\WCDMA PREFERRED"

Still not working?

Change NETWORK SELECTION to Manual
The device will perform a scan which could take up to 2 minutes. You'll be presented with a list of available networks. Choose Koodo or Telus from this list.Note: Doing this disables international roaming. Should you ever want to roam in the future you'll need to change this setting back to automatic

If your device still isn't working, check and be sure your bill is paid up and then give Tech support a call. It's free.

Reply