Koodo Community

Community

Question

Moto X Play random "no service" issue


I have a Moto X Play XT1563 stock 6.0.1 phone that will randomly lose signal, particularly when driving. If I reboot the phone the signal comes back every time but no amount of tweaking, toggling, or factory resetting seems to prevent the issue. Sometimes it will work perfect for days, other times it will drop signal over and over and I have to keep restarting.

I have tried using the data toggle, I have no data limit, I am not over my monthly usage, I have no custom settings in the network connection, LTE is preferred network, AP is sp.koodo.com, phone is updated, security patch 01/01/2017. I have no apps that toggle or control any wireless functions. I have tried uninstalling basically every app, and doing multiple soft and hard factory resets and cache wipes.

It happens in different areas all over the city, dense downtown areas, out the the country side. I drive for work and use my phone constantly for navigation and mileage tracking and it's a huge pain to pull over, reboot and restart all my necessary apps. But it happens so inconsistently I can't isolate any specific cause.

I have no other issues with the phone, no wifi or other network issues, no delayed texts connection issues. The phone is about 1 year old.

Has anyone had a similar issue?

Thanks

4 replies

Userlevel 7
So first I'd try replacing your sim card. If you're still getting the same results.... Find out if your phone is over a year old, if it's not you're eligible to have the phone serviced as the warranty might still apply. You can pickup a new SIM at any Koodo kiosk or koodo retailers.
Userlevel 7
Badge +4
You shouldn't have to reboot Apps due to loss of service issues - I have many apps running & using data that just pick up where they left off when I re-enter a service area having driven through a dead spot.  Seems deeper than simply losing service, so keep the idea of a warranty repair in mind.
Badge +4
Setting the preferred network type to WCDMA Only (3G) should help to improve signal reception. Go to: Settings > More > Cellular networks > Preferred network type - select 3G. Ran it this way for well over a year with my Moto X Play without issue. 

A network reset may also resolve the problem. Go to: Settings > Backup and reset - scroll down to and tap Network settings reset and follow the prompts. If the problem persists, follow Chad or David's suggestions.
1)Pull SIM and reprovision(put back in reader). 2) Manually search for a network (Telus/Koodo). Network type S/B 3G or LTE.

Reply