Koodo Community

Community

Solved

Moto G: Bluetooth phone earpiece problems : voice commands jump to okay google not my contacts


motoG 1st edition: had for 2 years Ihad it set up for bluetooth earpiece to make calls worked all this time but now when I push the blue tooth button to make a call My phone goes to okay google, not even Google NOw; okay google needs wifi or data I don't have a data plan nor wifi when Iam not at home : never had this problem before; Checked bluetooth on someone elses phone and it works perfectly? I need a fix

12 replies

Userlevel 7
Badge +4
Try going to Bluetooth. Forget all devices. And re pair it with your phone. Hopefully that helps.
Explain Yourself  How can I repair it  I tried everything even different apps  nothing works The only thing I didn't try was factory reset.
Userlevel 7
Badge +4
Allan Rudolf wrote:

Explain Yourself  How can I repair it  I tried everything even different apps  not...

Try googling it. Tons of videos on how to pair Bluetooth with moto g. There should be an option to forget. Or unpair that device. Than try re searching and add it back to your moto g.
Allan Rudolf wrote:

Explain Yourself  How can I repair it  I tried everything even different apps  not...

My bluebooth is paired and connected: I can give  voice commands to okay google but when I want to use it to phone a contact instead of going to google now and  just say call " ?" it jumps into a okay google search but doesn't connect me to my phone number like it used to.
Userlevel 7
Allan Rudolf wrote:

Explain Yourself  How can I repair it  I tried everything even different apps  not...

Have you tried saying call after the prompt?
Allan Rudolf wrote:

Explain Yourself  How can I repair it  I tried everything even different apps  not...

yes and evey other reasonal command that i thought might work like dial etc>
Userlevel 7
What Bluetooth device do you have?
Chad Burr wrote:

What Bluetooth device do you have?

samsung HM7000
Chad Burr wrote:

What Bluetooth device do you have?

I just disconnected the bluetooth device unpaired it turn the phone off restarted reconnected bluetooth to phone and the same old thing.
Userlevel 7
Chad Burr wrote:

What Bluetooth device do you have?

Goto settings... Applications.... Google and clear the defaults.

Then tap the Bluetooth headset button... See if there is a pop up that says "open with"

Make note of each app and try each app.
Chad Burr wrote:

What Bluetooth device do you have?

I tried that but when a  when i tap the bluetooth headset button nothing pops up:
If I try to make a call with WIFI on it goes through  with okay google however if I turn it off nothing happens saying iam not connected because okay google works with wifi not the phone like google now is suppose to or like it did befor i had this problem
Userlevel 7
Badge +4
Have you recently updated Google app or the Moto assist app? Have you tried going into the Google settings within the Google app and turning off Google Now voice recognition?

Reply