Koodo Community



Model network not available when I try to answer a phone call Nexus 4 Lollipop 5.1.1

Received an update to the 5.1.1 OS a few weeks ago, everything was good as it has been for the last 2 years. For the past 4 days I can dial out and receive the notification of a call, but as soon as it connects (as in they answer my call or I answer their call) the call is dropped and it says "mobile network not available". The network then reconnects within 30 seconds and everything is fine. I can access everything EXCEPT phone calls...can't call it a phone. 

I have done 2 factory resets, cleared the cache, toggle airplane mode on and off, manual APN, manual selection of mobile network, nothing works from what I have found through extensive research of online forums. Went into the koodo booth and they gave me a new SIM, no change, still no phone calls. Tried to flash the last update onto my phone - I am already up to date. The koodo rep was stumped and sent me away with no answer except call Google (I have no landline, that's why I have a cellphone). Please help.

7 replies

Userlevel 7
Hi Kevin,

How old is the phone? If you are within a year you can go to a Koodo Kiosk and have it shipped out through warranty. 
Hi Mathieu, The kiosk asked that, unfortunately it's about 2 years old.
Badge +4
I can only think of two options. An upgrade to a newer phone or trying your hand at downgrading to an earlier version of Android. Keep in mind that the current build of Lollipop contains the Stagefright vulnerability patch. If that's of no concern and the phone worked prior to the update and an upgrade isn't in the budget at the moment, this might be a route worth considering. Personally, I would go with an upgrade if possible.


Well the Stagefright patch seems to be the turning point for my phone, turning off auto-download MMS is much easier than not having a working phone. I don't think I want to buy a new phone when everything else works perfectly. So I will try the downgrade, thanks for the suggestion.
Badge +4
Kevin Payne wrote:

Well the Stagefright patch seems to be the turning point for my phone, turning off auto-download ...

You're welcome Kevin. As of about 45 minutes ago, we've received word of network issues/outages affecting various areas around Saskatchewan and Alberta. Clients will have no service in the affected area(s) and will be unable to place or receive calls or send SMS messages. If you happen to reside in either of the affected areas, the problem you've been experiencing may have been a precursor to a more widespread network issue. If not, kindly disregard. Update: the outage problem has since been resolved.
Unfortunately I am in Ontario, I was hoping it might be something like a network outage, but I can send SMS no problem while the phone calls still fail.
Good news! After a lot of trial and error getting the downgraded version of Lollipop 5.1.1 flashed onto my phone, I now have a fully functional smartphone again! Thanks for the suggestion rikkster