Koodo Community



Mobile network not available

My Samsung Galaxy S2 keeps losing reception saying "Mobile network not available" and I can't send/receive calls or texts. I have to turn it off and turn it back on again then it works (some others have suggested putting in airplane mode then turning airplane mode off, I'll try it but I shouldn't have to do this 3 times a day, it's also very dangerous/illegal when I'm on the highway to have to do this). The entire time my data will work just fine. What's going on?

2 replies

Userlevel 7
Badge +4
It's dangerous and not good practice to use your cell on the highway at all actually 😉 Did the phone work at one time and it just started doing this or has it been an issue since you got the phone? Are you within the 14 day return period? You can try to go into settings - more settings-mobile networks then click on network operators and let it manually search for towers then choose Koodo when the list of the owners comes up. and see if that helps. You can also try a new SIM Card & if neither of those work I'd say it may be the phones hardware it's self and you might need to return, exchange or repair the phone dependent upon how long you've had it as to what option will need to be taken.
I would normally use my cell through my bluetooth on the highway which is why I'm uncomfortable with turning it on and of from airplane mode while driving, because I know it's unsafe. But I'm travelling all weekend for long stretches on highways where it is dangerous to pull over so I'd really like a resolution other than turning it from airplane back to normal. The phone worked fine until today, I've had it a couple of months and never had this issue before. I've already checked the network operators and chosen Koodo since this started, problem persisted. It seems like I pass through a no reception zone and phone just stops trying to pick up signals, and the only way to get it working again is to restart. I'll try and find a koodo store in the area I'm currently in tomorrow if this persists.