Koodo Community

Community

Solved

Mobile data automatically turning on, how do i stop this?


I switch off wifi and then for some strange reason Mobile data turns on. Often it shows the LTE symbol but sometimes it's the H+. I can go into my mobile data through the settings > more connections > mobile networks and deselecting mobile data however it just turns on after a few minutes again. This goes on back and forth for a few minutes until it just stays off. The problem is mostly apparent when i turn on my phone after it being off. Recent it has also been showing the H+ symbol then I go to shut the data off but it claims to be already off so i have to turn it on then turn it off. Please help i don't actually have any data and this is going to accumulate me charges that i don't need. I've googled without success so here i ask for help 🙂 Thank you, Kris

5 replies

I have an S4, rooted running 4.4.x (I believe). I have know uninstalled and i don't know about kid mode as i've heard that may be connected.
Userlevel 7
Badge +4
Never heard of data turning it's self on, your rooted so are you running a custom ROM? If so maybe it's a bug in the ROM your running instead of the official ROM from Samsung.
Paul "Kid Android" Deschamps wrote:

Never heard of data turning it's self on, your rooted so are you running a custom ROM? If so mayb...

No it's still the stock rom just with Root permissions. I've seen a few others have the same problem online but haven't seen a solution yet. Any thoughts?
Userlevel 7
Badge +4
Paul "Kid Android" Deschamps wrote:

Never heard of data turning it's self on, your rooted so are you running a custom ROM? If so mayb...

Have you tried revoking root permissions? Does it still happen?
Paul "Kid Android" Deschamps wrote:

Never heard of data turning it's self on, your rooted so are you running a custom ROM? If so mayb...

I've revoked root permissions for all the apps that needed them and it's inconsistently solving the problem. It appears to be Adblock Plus that is causing the problem. However, it may be pushbullet or Lucky patcher. It seems to have limited itself to flashing the LTE symbol then disappearing. Any further thoughts?

Reply