Koodo Community

Community

Solved

MMS Stopped working after changing data plan


I signed up for Koodo 2 days ago to get the LG G3 at Walmart with the.gift card.  My number was ported over from Eastlink.

When I first setup my phone I was on the cheap $30 plan that had 200 minutes and 100 mb of data.  At this point I was able to send and receive SMS and MMS without an issue.

Yesterday I called Koodo and switched to the 49 dollar plan with unlimited minutes and 1 gig of data + bonus 1 gig and ever since doing so I have been unable to send or receive MMS messages.  I don't get an error message when I send, it actually looks like it goes through but never gets received by the recipient.  SMS still works fine.

I have confirmed data is turned on.  I have tried using the regular messages app and also integrated with hangouts and still have the same problem.

Can anyone help?  

PS this is my first post so I hope I provided enough information...

20 replies

Userlevel 5
When there is a plan change like that you usually need to shut off and restart your phone. Have you done that?
Thanks for replying.  Yes I did.  I also tried putting my sim in another LG G3 koodo phone (my wife's) and couldn't send mms with that either...
Userlevel 3
Sounds like you're doing everything right there, Joseph. I'd suggest getting in contact with Koodo tech support and ask them to try resetting the network connection from their end and see if that helps. Let them know all the troubleshooting you've done already as well!
Will do.  thanks guys
Userlevel 7
Have you tried sending message to yourself?
I didn't even know that was possible haha.  I just did now, it sent and I received it as well...
Userlevel 7
Joseph McAll wrote:

I didn't even know that was possible haha.  I just did now, it sent and I received it as wel...

Did you have an iPhone before? Does the other person have an iPhone? Ask them to turn off iMessage. If you still have your old iPhone, login to it and turn off iMessage as well.
Joseph McAll wrote:

I didn't even know that was possible haha.  I just did now, it sent and I received it as wel...

I did have an iPhone before but it has been wiped and I no longer have it.  Do you know of another way to disable it?  

I will have the other person try and disable it and report back as soon as I hear from them.

Out of curiousity, if it does work after they disable imessage, does that mean I won't be able to send mms to people that do use imessage?

Thanks a lot for the help and quick responses!  I'm still on the "callback list" for a koodo rep as well hahah
Userlevel 7
Badge +4
Joseph McAll wrote:

I didn't even know that was possible haha.  I just did now, it sent and I received it as wel...

You should be able to sign into your iTunes / iCloud account and disable your former iPhone from iMessage there.  In iCloud, you can go to the Settings icon, and disable the device there - there is a Lost / Sold option to remove devices from your account. This *should* address the iMessage issue as long as you do not have other devices also with iMessage activated on them.

You can email them the MM Message, and send a text to let them know it has arrived. Not as clean as just a message, but will get it to them.

@Chad Burr, I know I would not want  to lose the advantages of iMessage because one of my contacts switched phones.
Userlevel 7
Joseph McAll wrote:

I didn't even know that was possible haha.  I just did now, it sent and I received it as wel...

True@dfbutt on iMessage
Joseph McAll wrote:

I didn't even know that was possible haha.  I just did now, it sent and I received it as wel...

Thanks again guys.  I did log into my icloud and removed my device.  i also reset my icloud password.  I've sent a new mms message to my friend and am waiting to hear back from them.  
Userlevel 7
Joseph McAll wrote:

I didn't even know that was possible haha.  I just did now, it sent and I received it as wel...

Keep us posted!
Joseph McAll wrote:

I didn't even know that was possible haha.  I just did now, it sent and I received it as wel...

ugh so yeah you were right.  i can send when they disable imessage.  I tested this with 2 iPhone users - same issue.  I had a friend with a note send me an mms and I received it without a problem.  

It's really weird that I was able to send without a problem before I changed my plan though.  I switched from messages to hangouts around the same time though so maybe that's what broke it worse?  I dunno 😞
Userlevel 3
Joseph McAll wrote:

I didn't even know that was possible haha.  I just did now, it sent and I received it as wel...

Not sure what is specifically causing the issue here but I can tell you from personal experience I prefer to use other messaging applications available on android, especially when sending mms. Although with that said, since upgrading to a Moto X I've been using hangouts again and havent experienced any issues. 

Check out: Textra & Messenger (Google Inc.) & Handcent Next 
Userlevel 7
Joseph McAll wrote:

I didn't even know that was possible haha.  I just did now, it sent and I received it as wel...

I Prefer chompSMS over handcent, actually over all of them.
Joseph McAll wrote:

I didn't even know that was possible haha.  I just did now, it sent and I received it as wel...

I just tried the 2 apps suggested by taylor no go on either of them unfortunately.  I assume this is an apple/android issue more so than a koodo problem at this point.

I'm hoping that removing my device from icloud will "eventually" fix the problem.  I don't think i like not being able to send mms messages to iphone users.

Even with those issues I'm glad to know this community exists.  this forum seems amazing.  everyone is very willing to help out without cutting me up hahah.  At least koodo has that going for it because the brief phone support I've had so far was highly frustrating.

Thanks to all that took the time to help!  
Userlevel 7
Joseph McAll wrote:

I didn't even know that was possible haha.  I just did now, it sent and I received it as wel...

Try this website https://selfsolve.apple.com/deregister-imessage
Joseph McAll wrote:

I didn't even know that was possible haha.  I just did now, it sent and I received it as wel...

I just did that before you typed that message hahah.  it says "your phone isn't registered for imessage"  I'm guessing removing it from icloud turned it off. 
Userlevel 7
Badge +4
Joseph McAll wrote:

I didn't even know that was possible haha.  I just did now, it sent and I received it as wel...

It may take a while for the change to become effective.  Patience, Grasshopper!
Joseph McAll wrote:

I didn't even know that was possible haha.  I just did now, it sent and I received it as wel...

Just wanted to give an update.  It appears the iMessage change takes some time.  I can now successfully send and receive mms messages to iMessage users.  Thank you all for the fine help.

Reply