Koodo Community

Community

Solved

MMS send works, MMS receive does not


Userlevel 1
Hi.  I have a Samsung S6 running Android 5.0.1 on a Koodo prepaid account.  My friend has an iPhone 4s on Rogers prepaid.  I can successful send him an MMS.  If he tries to send me an MMS I get a notification that the message was not received.  I have Network node set to GSM/HSPA/LTE (auto connect). My APN settings appear to be correct based on what I've read in the other posts.

Any ideas?

9 replies

Userlevel 7
Badge +4
Is he trying to send you an iMessage possibly which Android devices obviously can not receive since it's a primary Apple service.
Userlevel 1
He disabled iMessage before he sent the MMS so that is not the problem.  However, I discovered today that if I change my Network Mode selection to either HSPA (only) or to GSM/HSPA (only) then I do receive the MMS he sends.  So, the question is, why don't I receive the MMS he sends if my Network Mode setting is GSM/HSPA/LTE (auto connect)?
Userlevel 7
Paul Calamai wrote:

He disabled iMessage before he sent the MMS so that is not the problem.  However, I discover...

It COULD be because of the fact Koodo doesn't have a GSM network but that shouldn't effect your ability to receive MMS whatsoever.

Is your S6 a Koodo phone or unlocked phone?
Userlevel 1
Paul Calamai wrote:

He disabled iMessage before he sent the MMS so that is not the problem.  However, I discover...

It is unlocked.
Userlevel 7
Paul Calamai wrote:

He disabled iMessage before he sent the MMS so that is not the problem.  However, I discover...

i thought so... THAT is what was most likely the problem then. Make sure your apn settings are right for mms

http://aide.koodomobile.com/Portals/0...
Userlevel 1
Paul Calamai wrote:

He disabled iMessage before he sent the MMS so that is not the problem.  However, I discover...

The only thing that is different in my settings is APN type which is set as default,mms,supl,dun
Is that a problem?
Userlevel 7
Badge +4
Paul Calamai wrote:

He disabled iMessage before he sent the MMS so that is not the problem.  However, I discover...

Try it without the dun I don't have that part of the line on my S6, mine just reads default, mms, supl
Userlevel 1
Paul Calamai wrote:

He disabled iMessage before he sent the MMS so that is not the problem.  However, I discover...

Funny.  I just created a new setup with APN type left blank and that worked!
So, now the problem is, what should APN type be?  Should it be blank (as in the link you sent) or should it read default,mms,supl  as yours is?
Userlevel 1
Paul Calamai wrote:

He disabled iMessage before he sent the MMS so that is not the problem.  However, I discover...

Sorry, I meant in the link that Ahmad sent.

Reply