Koodo Community

Community

Solved

LG G4 Data not working with APN settings


Just got an unlocked LG G4 from Telus. Insert a koodo sim card and text/phone calls work fine. Data and MMS do not work however. Tried multiple different APN settings, but still no luck. Any suggestions or is the phone useless on this network?

13 replies

Userlevel 7
Badge +4
Try these. See if this matches your settings please.

Tap the menu key.
Tap System settings.
Tap More...
Tap Mobile network.
Tap Access Point Names.
Press the Menu button
Tap New APN:
Name: KOODO
APN: sp.koodo.com
Proxy: 74.49.0.18
Port: 80
Username: leave blank
Password: leave blank
Server: leave blank
MMSC: http ://aliasredirect.net/proxy/koodo/mmsc
MMS Proxy server: 74.49.0.18
MMS Port: 80
MCC: 302
MNC: 220
Authentication type: No set
APN type: No set
Tap menu key, then tap Save.
Tap the radio button at the right of the Koodo APN to activate data services. ALso make sure your data toggle is on .
Userlevel 7
Badge +4
The phone is definitely compatible with Koodo so don't worry about that. If Chadwick's suggest at and confirmation of APN's won't fix it, toggle airplane mode, and if that doesn't work, pop the Sim restart th phone put it back in. Keep us posted.
Tried all that. Even tried another koodo sim and my sim in another phone. My sim worked fine in the other phone, other koodo sim didn't work either. Makes no sense. Could a factory reset do anything?
Userlevel 7
Badge +4
Patrick Lenaour wrote:

Tried all that. Even tried another koodo sim and my sim in another phone. My sim worked fine in t...

Sometimes yes. Worth a shot.
Userlevel 7
Badge +4
Patrick Lenaour wrote:

Tried all that. Even tried another koodo sim and my sim in another phone. My sim worked fine in t...

But before that, try switching network type to include, then exclude LTE, and manually connecting (may take a few minutes). Then do the process with the LTE on.
Alright so I just backed up, factory reset, restored and everything seems to be fine. Thanks for everyone's help.
Userlevel 7
Badge +4
Patrick Lenaour wrote:

Alright so I just backed up, factory reset, restored and everything seems to be fine. Thanks for ...

Awesome. Glad it worked.
Patrick Lenaour wrote:

Alright so I just backed up, factory reset, restored and everything seems to be fine. Thanks for ...

I have the exact same issue, tried literally everything except for factory reset. did you backup to SD ? how smooth was the restore ? I just did a backup to SD and it failed on a bunch of things, I am dreading the outcome of a reset even if it fixes the data problem
Badge +4
Patrick Lenaour wrote:

Alright so I just backed up, factory reset, restored and everything seems to be fine. Thanks for ...

Have you tried resetting network settings? This is usually found under Settings > Backup and reset > Reset network settings - follow the prompts. If that doesn't work, please read on.

Make sure there are no typographical errors in this line:
MMSC: http://aliasredirect.net/proxy/koodo/mmsc (there's no space between http and ://aliasredirect. It's printed this way so that it doesn't turn into a shortened link). 

Have you considered cloud storage for photos and/or music? (e.g. DropBox, Google Drive). LG offers software that allows you to backup your device, (link below). Your Google account will take care of restoring contacts and some app settings. Best to sync with your Google account before performing a factory reset.

Some app developers choose not to allow an app to be moved to SD storage as this may cause the app to perform undesirably or not at all.  

http://www.lg.com/us/support/product-help/CT10000026-1438110404543-preinstall-apps
Userlevel 7
Badge +4
Patrick Lenaour wrote:

Alright so I just backed up, factory reset, restored and everything seems to be fine. Thanks for ...

Try leaving both port and proxy fields blank and set the apn type to "default, mms" without the quotes.
Patrick Lenaour wrote:

Alright so I just backed up, factory reset, restored and everything seems to be fine. Thanks for ...

THIS WORKED! I was trying EVERYTHING and nothing was working, then I just erased the proxy and bam it was solid! THANK YOU!
Patrick Lenaour wrote:

Alright so I just backed up, factory reset, restored and everything seems to be fine. Thanks for ...

likewise!   LG-G4 and Koodo prefer the "default, mms" setting
Patrick Lenaour wrote:

Alright so I just backed up, factory reset, restored and everything seems to be fine. Thanks for ...

I (just went through this pain).
I have an LG G4.
Apparently this phone has issues when you change the SIM card more than once.
The solution, unfortunately, is to do a Factory Reset.
This is the only thing that worked for me.
Here's a link that will help:
https://productioncommunity.publicmobile.ca/t5/Getting-Started/Unable-to-get-data-working-on-lg-g4/m-p/62064#M10093 
After doing the factory reset, the phone will (automatically) set itself up with the correct APN settings.

PS - I hate that this was the only solution, but believe me, I tried (everything) else - to no avail.  If you have an LG G4, this is your only solution.  Just make sure you do the LG Backup to your SD card, and it will ease your pain (a bit).
There will still be a bunch of things to "put back" the way they were, but it is better than starting from scratch.
Good luck !

Reply