Koodo Community

Community

Solved

Issue with Instagram while on Koodo data


Userlevel 2
Strange situation, while I'm on data, Instagram doesn't refresh pictures getting the "Can't Load Pictures" error. Everything else works, browsing, email, Facebook, everything except Instagram. Now the funny thing, if I use a VNP like Opera VPN, Instagram works perfectly. If I'm on WiFi, works just fine. Only when I'm on Koodo data, it doesn't. I uninstalled and reinstalled the app a few times, and the problem persist.
Any idea why is not working on Koodo data, but works on data throught VPN only?

26 replies

Userlevel 7
Badge +4
Check to make sure your permissions for Instagram are allowing data to be used.
Userlevel 2
Chadwick wrote:

Check to make sure your permissions for Instagram are allowing data to be used.

I have no restrictions on the app or the phone (Android 6.0.1)
Userlevel 7
Badge +4
Have you tried uninstalling and Re installing installation?
Userlevel 2
Dennis wrote:

Have you tried uninstalling and Re installing installation?

Several times
Userlevel 2
Ok, I just checked my phone APN settings, and they were slightly different from the one on the support site (http://help.koodomobile.com/plans-add-ons-data-and-other-services/data-on-android/How-do-I-setup-dat...)
Somehow my phone included a setting under Proxy and Port (same as MMSC Proxy and MMSC Port), while the instructions above suggest to leave them blank. I manually made the changes and now it's working.
I understand these settings are automatically loaded when I connect to the network, maybe this is something that Koodo techs should look into it.
Jonny wrote:

Ok, I just checked my phone APN settings, and they were slightly different from the one on the su...

I'm experiencing the same problem as you, but my settings do match what the support site says. Weird though, for me I'm not seeing the support page as saying to leave them blank. 
Userlevel 2
Jonny wrote:

Ok, I just checked my phone APN settings, and they were slightly different from the one on the su...

This was the problem, my phone had Proxy 74.49.0.18 and Port 80. When I found this, I manually change the setting and it started working again. It's been working fine since I made the change.


Jonny wrote:

Ok, I just checked my phone APN settings, and they were slightly different from the one on the su...

Changed mine to blank - instagram is working, at least for now. Thanks!
Userlevel 2
Jonny wrote:

Ok, I just checked my phone APN settings, and they were slightly different from the one on the su...

Terry, just out of curiosity, what phone do you have? I have a OnePlus X, Android 6.0.1
Jonny wrote:

Ok, I just checked my phone APN settings, and they were slightly different from the one on the su...

LG G4. I'd have to check the Android version.
Jonny wrote:

Ok, I just checked my phone APN settings, and they were slightly different from the one on the su...

Oneplus 3T had the same issue! Thanks!
Jonny wrote:

Ok, I just checked my phone APN settings, and they were slightly different from the one on the su...

Also had this problem with my Oneplus 3T. Seems to mostly be a problem with Oneplus phones.
Jonny wrote:

Ok, I just checked my phone APN settings, and they were slightly different from the one on the su...

How do you do this on an samsung s4 android phone? I have the same problem with my instagram with Koodo
Userlevel 7
Badge +4
Jonny wrote:

Ok, I just checked my phone APN settings, and they were slightly different from the one on the su...

Settiings, Mobile Data, Mobile Networks, APN
Jonny wrote:

Ok, I just checked my phone APN settings, and they were slightly different from the one on the su...

That fixed it for me too! Finally! Thanks so much for the solution.
OnePlus2 here.
Jonny wrote:

Ok, I just checked my phone APN settings, and they were slightly different from the one on the su...

OnePlus One here. Same issue, same solution! Thanks!
Jonny wrote:

Ok, I just checked my phone APN settings, and they were slightly different from the one on the su...

Can you possibly spell out the instructions line by line for lg g4. I found the location for the settings for mobile data network mode etc. Just not sure what to change. Ty.
Userlevel 7
Badge +4
Jonny wrote:

Ok, I just checked my phone APN settings, and they were slightly different from the one on the su...

Its all listed above. Mobile Network, APN, Edit APN, then you want to clear out the Port and Proxy fields.
Jonny wrote:

Ok, I just checked my phone APN settings, and they were slightly different from the one on the su...

Thank you so much.  I've been trying to find a solution for some time now.  This worked perfectly.
Jonny wrote:

Ok, I just checked my phone APN settings, and they were slightly different from the one on the su...

Signed up just to say thank you for this. Worked like a charm on my OnePlus 3t. Phone wouldn't let me edit the koodo sp APN so I made a new one with all the same settings plus the changes indicated here.
Thank you Jonny! Had this same issue with my OnePlus 3 on Android 7.0. Clearing the proxy & port from the APN allows me to use Instagram without a VPN.
Thank you so much for this thread! I had been having this problem on my OnePlus 3. I also had an issue when I first updated to Android 7.0 where I couldn't send or receive texts or use mobile data at all. I flashed my device back to the previous version and just updated now and only had the Instagram issue which is now fixed. (Downside is I will be using a lot more data being on Instagram all the time...)
Thanks Jonny! Been searching the website for this solution for my OnePlus 3t.. And It works!
Same issue with my oneplus 3t. Your solution worked! Thank you!
This worked for my Xperia z5 as well. The link to the Koodo help page doesn't work but I just deleted out what I had put in Proxy and Port under APN settings. Thanks a bunch - this was driving me crazy

Reply