Koodo Community

Community

I think The Geek Squad broke my contract with Koodo by replacing my LG G4 with a refurbished FIDO phone.


My phone has no data and my account is now unreachable.

5 replies

Userlevel 7
Badge +4
I think you would need to contact the Geek Squad because they are the ones who started the problem.
I was trying to get into my account and my name, phone number and password do not match.
Geek Squad has no tech support; just receptionists.
The manager said having a Fido phone will work just fine on the Koodo account.
I guess I'll give them another call.
Userlevel 7
Badge +4
Eric Mattar-Hurlbut wrote:

I was trying to get into my account and my name, phone number and password do not match.
Geek Squ...

You would need to unlock that Fido phone before using on Koodo network. Or you could ask the guy at Geek Squad to setup for you, if they say the phone is fine on Koodo network.
Userlevel 6
Hi Eric, Sounds like they gave you an unlocked Fido LG G4 since you’ve mentioned that only data is not working. For data to work, you will have to configure your APN settings to have data turned on. Go to your settings, the find cellular, more settings, click access point names, press the add button. Then fill up the missing slots with the information provided in this link: https://www.koodomobile.com/help/setting-data-your-non-koodo-phone As for the invalid self-serve login, call in to customer service by dialling 1-866-995-6636 or get in touch through Koodo’s Facebook. As them to reset your self serve profile and send you a complete registration email. Just out of curiosity, when was the last time you logged in to your self serve?
I tried logging in about 19 hours ago. It's my son's phone, so I'll have to wait for him to come home to turn on data. I tried the Facebook question box, about 19 hours ago, but it is still unanswered.
Here, I was given suggestions within the hour, so I guess Koodo tech support is community run.

Reply