Koodo Community

Community

Solved

I'm not receiving all the sms that are sent to me, or they are mixed with old sms


Hi,

I have a prepaid Samsung Galaxy S3.
I had this problem for a few months now.
I don't receive all the sms that my friends are sending me, but they get all of mine.
Plus, sometimes, when they send a longer sms, their sms will get all mixed up : the first part of what they wrote is OK, but the second part looks like part from old sms they sent me months ago.

My friends don't have this issue when they send sms to others of our friends.

What can I do?

4 replies

Userlevel 7
make sure the time and date and time zone settings for your device are correct.
Everything is correct. 😕
Userlevel 7
Badge +4
You can go into Settings => Application Manager and choose the Messaging App. Delete the data and settings. You will lose all the messages stored on the phone, but will start with a clean slate.

If you are concerned about saving existing messages, install Mighty Text or something similar from the Google Play Store before you clear the phone. This will let you mirror  or backup your SMS messages from the phone to an outside laptop or desktop computer.
Userlevel 6
Hey Stephanie! Did Bob's suggestion work? Keep us posted! 

Reply