Koodo Community

Community

Solved

i have a samsung galaxy s4 and it is not running LTE, just 4g. How can I fix this?


I just got a samsung galaxy s4. It runs fine in 4g but I have never been able to connect in LTE. Is there a setting that is incorrect or is there something wrong that needs to be fixed?

2 replies

Userlevel 7
Badge +4
Are you sure your in an LTE coverage area? Check the coverage maps for Koodo. Also make sure LTE in enabled in the settings under network settings.
Userlevel 3
Hello James,

Paul is right, it may be possible that the area where you are doesn’t have LTE coverage. You can check this on our coverage map by following this link: http://koo.do/JbHkbm .

Also, you can see if the LTE settings are enabled by going to Menu—Settings—More—Mobile Networks—Network Mode—then choose LTE/WCDMA/GSM .

Let us know how this worked!

Reply