Koodo Community

Community

Solved

i cannot make calls on my samsung galaxy s2?


2 replies

Userlevel 7
Was it working before and now it's not? We need a bit more info. Does your phone say "Emergency calls only"? Make sure airplane mode is off, then go Settings > More... > Mobile Networks and make sure "Only use 2G networks" is NOT checked. Then take out your battery and SIM card for about a minute, reinsert them into the phone, turn it on, and try placing calls again. Koodo doesn't use 2G, so having that option enabled basically turns your phone into a small Android WiFi only Tablet.
Userlevel 7
Badge +4
Can you text? Does it say no network, if so then try what Jonathan said

Reply